CPU package power does not show in system tray settings on restart

ceevee

New Member
WIndows 10 x64

I select CPU package power to always show in system tray. After restart, it is not showing. It is in the "hidden icons" section of the system tray, where you have to click the arrow to show the rest of the system icons.

If it is in this hidden section, it does not show in "Settings->Personalization->Taskbar->Select which icons appear on the taskbar."

After I drag the CPU package power icon out of the hidden section and to the right, it then shows in "Settings->Personalization->Taskbar->Select which icons appear on the taskbar."

However, after I restart, it is in the hidden section again, resulting in it not showing in "Settings->Personalization->Taskbar->Select which icons appear on the taskbar" as before.

I tested with another sensor (e.g. VID), and this behavior does not occur. It works properly with other sensors. For now I have to select "Always show all icons in the notification area" to show CPU package power after restart. Unfortunately this shows other non-Hwinfo icons that I do not want.
 

Martin

HWiNFO Author
Staff member
I'm afraid I don't know how to solve this.
Icon appearance in the taskbar is fully managed by Windows, applications have no control over the placement.
 

ceevee

New Member
I was able to fix this. I enabled "Always show all icons in the notification area", restarted, then disabled "Always show all icons in the notification area". Now all activated hwinfo system tray icons appear and selecting them to appear in the system tray persists after restart.

Must have been a minor Windows bug, and not a hwinfo bug.
 
Top