[DELL Inspiron 5558] Fan showing 0 RPM post-restart. It initially worked once after disabling EC.

iamnotarobot

New Member
Hi,
I've got a Dell Inspiron 5558. I am running windows 10. I updated Bios to the latest version and used HWinfo64 latest stable version (6.3). Initially the fans were working properly.

I used HWinfo and at first nothing happened. Then when I disabled EC sensors from the same dialog box which appears after clicking on sensors. Then I set my fan on full (set manual), it worked. I played a game for about an hour then changed it to system auto mode. Everything was working fine till I shut it down. I expected it to become okay but post restart the fan has completely stopped working (it actually isn't moving) and HWinfo shows 0RPM. The laptop is becoming hot now and then. I tried SpeedFan it also shows 0RPM. Other similar utilities can't even detect the fan.

I flashed latest bios again, took out battery, restored bios to default. Nothing happened. When I run hardware diagnostics from bios it says the fan failed to respond correctly. The system usually heats up and cools on its own. Fan is shut for about two days now. I was thinking about resetting the Real Time Clock but I don't have the tools. Although Dell 5558 supports it from the power button only but I don't know why it's not happening. ( https://www.dell.com/support/articl...-to-recover-your-dell-portable-system?lang=en ) . I went through numerous articles and although I can't be very sure but I think that instead of the fan the thermal sensor might be faulty too.

I've attached the log here (including sensor data). Please suggest something. The dilemma is that if the sensors are faulty in some way then changing the fans won't help.

What should I do?

Thank you.
 

Attachments

Last edited:

Martin

HWiNFO Author
Staff member
If removing the battery and disconnecting the power plug for a couple of minutes doesn't help, then this might be some hardware failure and you should consider a RMA.
 

iamnotarobot

New Member
I went to the local stores. Coincidentally, just the day after installing HWinfo my fans jammed because of dust. It's working now. I wonder why were they not detected.
Anyways things I tried before getting it done:
-Safe mode
-Resetting RTC

Thanks
 
Top