Fan Control looses settings

DeeX

New Member
I have everything setup properly. However when windows starts my fan control settings are lost. 
I am trying to do a manual fan control setting the fan to 4000 RPM. When I do this and press "set manual" the fans ramp up and go as expected.
However when I reboot then program opens, I see the fan control panel open for a second and then it auto minimizes. However the fan settings I chose prior to reboot are lost and the manual setting is set back at 0. What am I doing wrong?

I have OpenFanCtrlMin=1

Everything seems to work as far as auto start except for the actual fan setting. 

Please help!
 

Martin

HWiNFO Author
Staff member
Manual fan speed setting is not intended to be preserved, it was though to be used for testing purposes only.
You might achieve the desired speed by defining a custom auto fan speed for a single level that will always be true (i.e. 4000 RPM when temperature < 120 C). Such setting will also be preserved and applied always after reboot.
 

njseq

New Member
Hi Martin,
Can you please help me out enabling the fan to a specific value each time the computer reboots? I can setup the manual fan and it works, but as DeeX said, each time the system reboots and even with HWInfo in system tray it does not start the fan...
Thanks.
Kind regards,
NS
 

Martin

HWiNFO Author
Staff member
You will need to setup a custom fan profile, that will be saved and set upon starting HWiNFO.
 

njseq

New Member
Hi Martin,
Thanks for answering but I've setup the custom fan from there I cannot get it enabled.
What is missing? Please see the attached print.
Thanks a lot!
NS
 

Attachments

Martin

HWiNFO Author
Staff member
That's not fan control setup, but adjusting of the value shown.
Click the fan icon at bottom of the sensors screen.
 

njseq

New Member
Hi Martin,
Thanks for answering but I've seen that fan icon and the sensors, and when I click manual and set the rpm, then I click save, but it changes back to Auto... does not save...
Thanks.
Kind regards,
NS
 

Attachments

Martin

HWiNFO Author
Staff member
The Set Speed manual setting is a single-shot (one time) only. You will need to modify the values in the LUT table below and click Apply and Save. Then every time HWiNFO is started again and sensors window active, those settings will be re-loaded.
 

njseq

New Member
Hi Martin,
Thanks for answering.
I tried that and as soon as I click the Apply and Save button it changed to AUTO and the fan stopped working.
I'm attaching the files to see. The original is the original setting, then I changed the rpm values still with Manual, and you can see the FAN rpm is spinning, then if I click the Apply & Save, the window becomes grey and the FAN stopps, no rpm...
So I need your help please... the laptop is a HP Elitebook 2540p.
Thanks a lot.
Kind regards,
NS
 

Attachments

Martin

HWiNFO Author
Staff member
I'm sorry, but I don't know why it behaves that way. Try the SpeedFan tool if that will perhaps work.
 
Top