GTX 1080Ti Sometimes GPU sensors show and sometimes they don't.

MitchB

Member
I have 1 onboard GPU and and extended GPU GTX 1080 Ti.

I have recently reinstalled Windows 10 and since then I get this issue that sometimes when I boot the PC I don't see the extended GPU(1080Ti) sensors in HWInfo64. After I the reboot the PC, 1080Ti sensors are there.

I have noticed, that when I see only 1 GPU(1080Ti) in Task manager then the 1080Ti does not show up on HWInfo Sensors, but when Task manager shows 2 GPU's then the 1080Ti sensors show on HWInfo.

See attached screenshot.

I have the latest build of Windows, the latest HWInfo version, all the latest MB drivers and bios, as well as the latest GeForce driver for the GPU. The MB is an Asus TUF Z390-plus gaming (WiFi) if it helps.

Any ideas why this is happening?

Thanks :)
 

Attachments

  • HWInfo64_No_GPU.jpg
    HWInfo64_No_GPU.jpg
    4 MB · Views: 3
  • W10-DT.HTM
    159.1 KB · Views: 1

Martin

HWiNFO Author
Staff member
This is most likely because the 2nd GPU is disabled by system when there's no load on it to preserve power.
Starting some task on that GPU (or sometimes even opening the NVIDIA Control Panel) should make it appear.
Alternatively you might try to enable the "Wake disabled GPUs (Extended)" option if that will do it as well.
 

MitchB

Member
Hi Martin,

Thanks for your reply.

This is not the issue. In BIOS extended GPU is set as default. In windows both GPU's are connected to HDMi but only the desktop on the extended GPU is enabled (Show only on 2).

Sometimes I boot the PC and in Task manager I see only the extended GPU as GPU 0 and when I open HWInfo, there are no sensors showing or the extended GPU. Then, without changing anything, I simply reboot and task manager now shows Internal GPU as GPU 0 and extended GPU as GPU 1 and when I open HWInfo the Sensors for extended GPU are present. As in the attached file.
 

Attachments

  • HWInfo64_No_GPU.jpg
    HWInfo64_No_GPU.jpg
    4 MB · Views: 4

Martin

HWiNFO Author
Staff member
Please check the end of the sensors list if it's perhaps located there. If not, please attach the HWiNFO Debug File from both situations (before and after reboot). I will need to analyze this in more detail.
 

MitchB

Member
Ok, here is the debug file from when it is working as it should. As soon as this happens again, I will attach the debug file from when he GPU sensors do not appear.

Thank you for your time :)
 

Attachments

  • HWiNFO64_Showing_GPU_Sensors.DBG
    1.4 MB · Views: 1

MitchB

Member
Oh, ok got it :D

The next time this happens I will check if the GPU sensors are at the end of the list, as well as attach the debug report.
 

MitchB

Member
So far I have tried several reboots and each time the GPU sensors appear as they should. I guess I will just have to wait for it to happen again and then I will post the info.
 

MitchB

Member
Hello Martin,

I have managed to reproduce the issue. The GPU sensors were at the end of the list as you suspected.

I am curious why this happens precisely when the task manager only shows 1 GPU.

I have included the debug file, just in case you might be wondering why this sometimes happens.

Thanks again for your suggestions and efforts. Have a lovely evening.
 

Martin

HWiNFO Author
Staff member
This is because of custom sensor order that you used. With this mode enabled when the GPU changes its index (#0 -> #1 -> #0) HWiNFO loses position of that item and adds it at the end of the list.
It's just an issue of appearance and enabling "Fixed order" back should resolve that.
 

MitchB

Member
I see. I didn't even know there was an option for fixed order.

Next time it loads correctly I will tick fixed order and hopefully that will resolve the issue.

Many thanks :)
 
Top