HDD temperature and smart data missing from 2 drives of a 4 drive Raid 10 array windows 10 2004.

sgtsixpack

Active Member
I zipped up 3 .dbg files, check date one is from April when everything was fine and I was in AHCI mode. Now I'm in RAID mode and 2 of my drives' stats are missing. I have 2 external hard drives ATM, 1 a 14TB WD elements (4 identical shucked drives inside O11 daymaic XL) & the other a 1TB WD10EACS via USB 2.0 to sata II adapter. I've set startup to 2mins (no write cache enabled) since I'm booting from the array (till I can clone to a USB/ figure out how to selectively clone partitions while keeping data partition of SSD intact).
 

Attachments

  • HWiNFO64.7z
    180.3 KB · Views: 1
  • HWiNFO64.7z
    328.4 KB · Views: 1
Last edited:

Martin

HWiNFO Author
Staff member
I think this is some issue of the RAID controller driver which doesn't support standard queries to report information about drives in the RAID array.
Is there some other tool (i.e. CrystalDiskInfo) able to report details about those drives?
 

sgtsixpack

Active Member
Hi Martin, thx for the response. I can tell you that crystaldiskinfo works 100% but defraggler (one of my 2 favorite defragmenters) crashes when asked to scan any partition of the 26TB array. In fact I checked a bunch of installed programs and found that crystaldiskinfo is the only one that can see my drives in the array (apart from driveXpert2 ofcourse https://www.amd.com/en/support/chipsets/amd-socket-am4/x570). ClearDiskInfo, Gsmart and Samsung Magician (old version could not recognise its own drives as made by Samsung); all fail to see through the array.

Pretty terrible results from HDtune but I've tested the drives individually for nearly a week with datalifeguard diagnostics and lowlevel (which itself now does not see the individual drives), they are fine. If I test from a cloned OS on the sata 3.0 port via a sata 2.0/ide to USB adapter the results exclude the background noise of OS disk activity. I have seen a max of 265MB/s in HDtune (higher than the 220-230 max of a single (faster drive like BXC)). I have seem some cache like reports from defraggler when hitting benchmark more than 2-3 times of 1250MB/s, not sure why as apparently onboard cache is disabled while in an array (I heard WD reds have limited onboard cache due to this fact; while these US7SAP140/WD140EMFZ have 500MB on board); and ofcourse no write caching enabled in the bios.

I have a UPS on the way from ebay (to protect against data loss on power cut) which seems like a bargin having checked the new price (just needed to order some c13/c14 cable variations), I need to check if a usb cable (for auto-shutdown on power loss) is required but I think I might find one at my Dad's house.

Edit:. Just noticed in in safe mode for sata drive scan.
 

Attachments

  • HWiNFOreport.png
    HWiNFOreport.png
    364.6 KB · Views: 6
Last edited:

Martin

HWiNFO Author
Staff member
Am I assuming correct that the drives missing in HWiNFO are the last two "WDC WD140EMFZ-11A0WA0" seen in RAIDXpert2?
 
Last edited:

Martin

HWiNFO Author
Staff member
This seems to me like a faulty implementation in the RAIDXpert2 driver - it doesn't provide correct information according to the specification.
CrystalDiskInfo seems to use some workaround for this, but according to the information I saw it's not quite reliable and might cause BSODs.
Hence I'm quite reluctant to try it that way...
 

sgtsixpack

Active Member
Is this raidexpert2 driver installed over the top of the drivers needed to be injected into the Win10 2004 install media? I can check this as long as my clone does not have raidexpert2 already installed. If so I can try reinstalling the base driver back. It's also possible there is no difference, but I recall talk of an AHCI driver included with raidXpert2.

If it's the same driver I will make a support ticket with AMD.

The idea of installing RaidXpert2 was not the driver but the taskbar monitoring of the array.
 

Martin

HWiNFO Author
Staff member
Sorry, I don't know if that will help.
What I can say (without going too technical) is that the RAIDXpert2 driver supports a standard called CSMI SAS, which is used to communicate with the drives including RAID arrays.
But the implementation by RAIDXpert2 is faulty as the drives reported in your case are only 4 and it seems one needs to force certain queries to detect the others, but this might cause issues. Besides that, some other parameters reported are also not correct and lacking requirements defined in the standard.
Solutions from other vendors (i.e. Intel RST) follow the specification much better and don't have such issues. So IMO this is a case for ticket at AMD.
 

sgtsixpack

Active Member
Do you think I've been hit with this bug?:


I have done a few more tests and I notice that even my SSDs seem to be cacheless. Tests can be bottomed out by flicking to a different program (with regards to HDtune test output).



I might need to reinstall over because I failed to backup a snapshot before I installed raidXpert2 with its drivers (they were an option). I will try again but unless I'm mistaken you can't install the OS onto one of the drives not specifically setup via the bios interface; namely the SSDs not intended to be used in RAID. I haven't tried not sure you can change drivers back now. There are 3 drivers that need to be manually updated and I'm not sure what happens mid process. I'm not concerned with data loss (have 2 backups).

Just sent AMD my report about this (and I've finally got my SSD as boot):
"
I installed windows 10 2004 direct onto my (at present) cacheless array; windows wouldn't install to an SSD in raid mode. When I shutdown from the array (with 2 x ssd plugged in) the reset never happens - it sits at black screen. The performance is terrible because of no-cache and disabled onboard cache. I was finally able to put my live install onto my SSD (with a Sabrent 2.5" USB3.0 adapter), I gave up with clonezilla. When I changed the boot order, the 850 evo failed to boot into windows. I removed an external hard drive and the order happened to default to the 850 first (probably because I knew which ports are enumerated first) then my 2nd SSD was not recognised. It is now but the experience is not one of a polished product. Why does RAID disable the cache on my SSDs when they are not in a raid array?

I have a screenshot of the original problem.

Defraggler crashes when trying to analyse the raid array, lots of software doesn't work apparently due to the driver not complying with standards (see my forum link)."

I also left feedback for microsoft on the issue, and linked amd & microsoft to this thread!
 

Attachments

  • RAID_8drives.png
    RAID_8drives.png
    1.5 MB · Views: 0
Last edited:

sgtsixpack

Active Member
I think I must have reinstalled since my last post because I have none of those problems I was talking about in my last post.

I gave up trying to install a live OS on a USB stick, I put my internal SSD into an external 2.5in ssd enclosure and used Macrium reflect. I was away for a week and when I came back my monitor C24FG73 Samsung had died, and the array was offline. I hooked up a backup Samsung, now I am typing on a Fi27Q-P Gigabyte. The array was not only offline but had "failed", I rebooted into windows 10 from the external, and upon reboot the array was back. I have now installed RaidXpert2 with the latest drivers from AMD, and I have done a full scan (took more than 2 days) of the 28TB RAID10. It seems like its going ok now, the performance is deceptive, when I use freefilesync the array always finishes before the external drives (14, 8 & 4TB) have, and it contains the primary copy of the data which is on the 14TB & another copy on the 8+4TB.

After installing the raidxpert2 software I notice that I have only 3 drive temperatures available in HWiNFO, completely misses both SSD temps and only shows 1 of the 4 raid 10 drive's temperatures. I was using an older driver without raidxpert2 and I saw all the drive temperatures (but it seems like they enumerate differently on every boot), but now with the latest drivers included with drivexpert2 again, only 3 temperatures are present in HWiNFO and I have a fantom drive called XVDD2.
 

sgtsixpack

Active Member
Hi Martin,
Can u have a look at my registry settings for HWiNFO and tell me if there is any references to hard drives or hard drive temperatures? Since the last time I've fresh installed (for version 2004) I have kept multiple backups and images so that I can rollback to an earlier version but that was before I learned that you must delete the HWiNFO registry key completely before merging a backup (or edited backup). I've used notepad++ to find references to hard drives and their associated temps, but after this: the clean 4 drives and 4 temperatures (for the raid array) is slightly crooked (only 3/4 drives have corresponding temperature readouts).

I have removed all drives deleted all arrays (in the bios) except my raid10. I just installed a Sabrent Rocket 4.0 (good prime day price £117), and an MX500 2TB (£156 on prime day), I removed an 850 evo, and moved my 860 evo into its sata port. I ended up with 5 or 6 arrays in the bios and with a raid10 I only have 2 sata+2 m.2 slots meaning only 5 arrays are actually possible (if you configure a single drive as a raid volume it counts as an array even though its a single disk).

So I have been using the MX500 in "legacy" mode meaning its not configured as a single disk raid array, and I was getting 400MB/s+ from 860evo (my raid10 can also do around this speed if its a large file transfer).

I've done some tests on my Sabrent Rocket 4.0 and I was not hitting 5000MB/s in crystal diskmark with it in legacy mode (there was no option to switch on windows caching and the manufacturer supplies no configuration software (Samsung's and Crucial's software refuse to work with windows 10 2004 in raid mode)). I have configured it as a raid volume now (I want to leave the MX500 as legacy as it apparently has some kind of power loss immunity onboard (I have a UPS too). I have not finished testing the Sabrent.

My initial request was for you to take a look at my registry settings, and I'd still like that but could you not make the registry settings be more readable? Or at the point you click backup settings, you could spit out a reference file for the numbers which are used as the key headings in the registry?

Only other thing I can think of is to delete the registry key and merge small sections of the backup file to see what appears in HWiNFO and create my own reference file. That device manager sceenshot is outdated.
 

Attachments

  • Crystal Mark Sabrent N (legacy No WC).png
    Crystal Mark Sabrent N (legacy No WC).png
    26.4 KB · Views: 3
  • HDTune_Benchmark_AMD-RAIDCT2000MX500SSD1(NoWC).png
    HDTune_Benchmark_AMD-RAIDCT2000MX500SSD1(NoWC).png
    28.8 KB · Views: 1
  • HDTune_Benchmark_AMD-RAIDSabrent_Rocket_4(NoWriteCache).png
    HDTune_Benchmark_AMD-RAIDSabrent_Rocket_4(NoWriteCache).png
    28.5 KB · Views: 1
  • HDTuneSabrent2020-10-26 (1).png
    HDTuneSabrent2020-10-26 (1).png
    32.6 KB · Views: 4
  • Disk3Raid10,850rOSD(Disk4)Line3,WULrSensors(Disk0)Line4-.png
    Disk3Raid10,850rOSD(Disk4)Line3,WULrSensors(Disk0)Line4-.png
    2.1 MB · Views: 4
  • HWiNFO.7z
    14.5 KB · Views: 1

sgtsixpack

Active Member
The forth value has appeared! Screenshotted it. I'm not happy with the Sabrent's performance but perhaps its a consequence of using system ram as cache as opposed to onboard (which is unavoidable when windows is installed in raid mode apparently.

Also the abysmal first screenshot is maybe titled wrong? Or a reboot fixed it more likely. Still its not 5000MB/s, maybe I should ask on gigabyte's forums. Would running my RAM over 3600MT/s 16, 16, 15, 15, 32, 288 geardownmode enabled help? Edit: That forth test is my Raid10 array with 4 x 14TB drives.
 

Attachments

  • Crystal Mark Sabrent N (legacy No WC).png
    Crystal Mark Sabrent N (legacy No WC).png
    26.4 KB · Views: 4
  • Crystal Mark Sabrent N RaidVolFail.png
    Crystal Mark Sabrent N RaidVolFail.png
    28.9 KB · Views: 4
  • SabrentRocketDesktop.png
    SabrentRocketDesktop.png
    573.8 KB · Views: 2
  • HDTune_Benchmark_AMD-RAIDArray_1_9.3.0.206setup.png
    HDTune_Benchmark_AMD-RAIDArray_1_9.3.0.206setup.png
    27.7 KB · Views: 4
Last edited:

sgtsixpack

Active Member
I went through the file with notepad++ and its compare plugin, cleaned out any old settings. I have yet to add my hard drives but my filesize went from 332kb to 154kb from all the junk of old builds. There should be some disclaimer or warning to first delete the registry entry before merging. Thanks for the useful program.
 

Martin

HWiNFO Author
Staff member
Those settings are not meant to be merged/modified directly by users. So best practice is to clear them (you can use "Reset Preferences" button) and start from scratch if such modifications in hardware are done.
There are also reports of issues from other users and I'm still thinking how to solve such situations, but haven't found a reliable method yet. Using some unique identifiers might be a way but this can't be applied to most items.
 

sgtsixpack

Active Member
Those settings are not meant to be merged/modified directly by users.
Perhaps if you allowed to import the registry settings, directly rather than indirectly merging with the registry (it must be the intended use of creating a user .reg with backup settings); then you could filter in some way, perhaps go through the detect all devices routine (like on program startup), and fill in any blanks/remove obsolete entries. Just my suggestion (I have not learned to code). For example look at the export/import fucntion of the AMD Radeon software.
 

sgtsixpack

Active Member
I have more information regarding the operation of your program and the operation of single disks configured as raid volumes.

The Raid arrays 1,2,3 are correct. Disk 4 from disk management is the raid10 array of 4 disks. 2 of my SSDs are configured as single volume raid arrays in the bios. Namely the 860 pro and the Sabrent rocket. The MX500 is as a legacy disk (apparently has immunity from dataloss while configured by default). There are 3 externals on wd elements usb 3.0 interfaces (WD140EMFZ, WD80EMAZ & HDN726040ALE614). The drives in the RAID10 array are also WD140EMFZ. There is an anomaly with "RAID array #3", this is confused 3 drives are part of the raid 10, 1 is the 860 single disk array volume, other is mx500 legacy disk; these obivously should not be listed as part of a single array. The last entry I can see is "AMD-RAID Configuration" and I have no explanation as to where that is coming from.

Onto the second point. I noticed that while defragging (and benching the sabrent at the same time) that the sabrent regained its greater than pcie 3.0 speed after finishing defragging a partition which is part of the raid10 array. So the system ram is a shared resource and therefore performance is impacted when using multiple "arrays" at once (raid10 or single drive array makes no difference they both share system ram).

Ofcourse now I will set my sabrent up as a legacy drive (I could not install to the 850evo in this configuration, I installed to the raid10 array for the initial install, and have cloned ever since), and clone windows 10 onto it. I will delete the 860 evo & sabrent rocket raid array entries in the bios; and run them in legacy mode. Reserving the shared cache, although 32GB, its capacity has no bearing with a performance loss of 100x for the sabrent when the caching is being utillized by two different Raid volumes).

Edit: I can try merging the file I cleaned rather than the settings I saved after editing a couple of settings I removed by accident. I did not run it with my normal settings as I was more concerned with how to get my readouts on my LCD and RTSS back.

I will test again once I have all my SSDs in legacy mode again.

Although I can't seem to get the Sabrent Rocket 4.0 to run at rated speed, for the price I paid, I'm not concerned (still over 4000MB/s write in legacy or raid mode).
 

Attachments

  • HWiNFO Summary.png
    HWiNFO Summary.png
    71 KB · Views: 2
  • HWiNFO Summary+DiskMan+SabArray.png
    HWiNFO Summary+DiskMan+SabArray.png
    327.8 KB · Views: 2
  • HWiNFO Summary+DiskManagement.png
    HWiNFO Summary+DiskManagement.png
    348.7 KB · Views: 1
  • HWiNFO64.7z
    248.1 KB · Views: 1
Last edited:

Martin

HWiNFO Author
Staff member
That issue with "RAID array #3" is because the RAID driver doesn't follow the specification fully and is not returning correct information about RAID sets present. It says there are 4 sets, but each of them with 1 drive only, moreover it doesn't fill the addresses fields, so an application is unable to determine to which particular set a drive belongs to. Let's hope AMD will improve this in future...
 
Top