High memory usage

kenichiA380

Well-Known Member
Hello!
I continuously ran HWiNFO for 1 month (maybe less... I'm not sure because i was away from my PC for 1 month), then my Windows 10 tells me "not enough memory. please close program HWiNFO." (I'm using Japanese environment so i don't know is this translation correct...) and I closed and restarted HWiNFO.

Now HWiNFO continuously ran 3 days and it used 4GB since before i start HWiNFO.

My system has 24GB of RAM.
 

Martin

HWiNFO Author
Staff member
What settings in HWiNFO do you use, are you running with Sensors-only ?
 

Martin

HWiNFO Author
Staff member
Well, those settings look OK.
You'll need to try to disable monitoring of sensors one by one and see which of them is causing this by watching if memory usage still grows.
You can do this by hitting the Del key on the sensor heading. I propose to start with the SMART sensors.
If you find the one causing this, please let me know which is it.
 

kenichiA380

Well-Known Member
Martin said:
Well, those settings look OK.
You'll need to try to disable monitoring of sensors one by one and see which of them is causing this by watching if memory usage still grows.
You can do this by hitting the Del key on the sensor heading. I propose to start with the SMART sensors.
If you find the one causing this, please let me know which is it.
okay... i will do this weekend. :s
 

kenichiA380

Well-Known Member
Martin said:
Well, those settings look OK.
You'll need to try to disable monitoring of sensors one by one and see which of them is causing this by watching if memory usage still grows.
You can do this by hitting the Del key on the sensor heading. I propose to start with the SMART sensors.
If you find the one causing this, please let me know which is it.
Look likes my second GPU is doing something. I'm using two R9 390X with crossfire enabled. Driver version is Radeon Software 17.9.3
After disabled these sensors, HWiNFO still grows my memory usage. But it is now less than before.
 

Attachments

Martin

HWiNFO Author
Staff member
Well, memory usage should not be constantly growing at all. Which of the GPU sensors is causing it, the main one or the others (PMBus) ?
 

Martin

HWiNFO Author
Staff member
This could be a driver problem. HWiNFO retrieves some information from AMD drivers and they could be causing the memory leak.
Can you try to enable only the heading of the first sensor and then check if memory usage start growing again ?
 

kenichiA380

Well-Known Member
Martin said:
This could be a driver problem. HWiNFO retrieves some information from AMD drivers and they could be causing the memory leak.
Can you try to enable only the heading of the first sensor and then check if memory usage start growing again ?
it started growing. it grows between 100~1000KB in 10 sec.
 

Martin

HWiNFO Author
Staff member
Well, I think it's a driver problem. It might be due to CrossFire. Can you try to disable CrossFire and see if memory grows after enabling those sensors in HWiNFO ?
 

kenichiA380

Well-Known Member
Martin said:
Well, I think it's a driver problem. It might be due to CrossFire. Can you try to disable CrossFire and see if memory grows after enabling those sensors in HWiNFO ?
Disabled crossfire and no more growing.
 

Martin

HWiNFO Author
Staff member
That confirms it's a driver problem. I will submit this bug to AMD and see if they can fix it in upcoming Crimson versions.
 

Martin

HWiNFO Author
Staff member
AMD is requesting more information about your system in order to reproduce this problem.
Can you please attach the HWiNFO Report File and Debug File ?
 

kenichiA380

Well-Known Member
Martin said:
AMD is requesting more information about your system in order to reproduce this problem.
Can you please attach the HWiNFO Report File and Debug File ?
Here it is.

Please use Shift-JIS for character encoding.(I'm using Japanese)
 

Attachments

Martin

HWiNFO Author
Staff member
Thanks. Was this done with Crossfire enabled ?
I also see that you upgraded to Crimson 17.10.1. Does the problem persist there ?
 
Top