How to Disable Drive Scan without opening the HWinfo?

StayFrost04

New Member
Hello there. I have installed HWinfo v6.02 and the software makes my system crash at the startup when its detecting everything at "S.M.A.R.T. #0" where it freezes and then causes my system to crash. It started happening ever since I installed AMD StoreMi so I guess that's the culprit, given how it crashes at "S.M.A.R.T. #0". Anyway, I heard that disabling Drive Scan will fix this issue but the problem is I can't open the HWinfo app in the first place to disable drive scan. 

Is there any way to disable Drive Scan without opening the HWinfo App? So far I've tried modifying the "HWiNFO64.INI" file found in C:\Program Files\HWiNFO64 and change all the values from "1" to "0" that mentioned "Drive" in their name but it still crashes on "S.M.A.R.T. #0" on startup. How do I disable Drive Scan without opening up the App?
 

Martin

HWiNFO Author
Staff member
By default HWiNFO should be showing the welcome dialog, where you can click Settings, but I suppose you disabled this prompt.
Manually you can disable Drive Scan by editing the HWiNFO64.INI file and change the HighestIdeAddress entry to:
HighestIdeAddress=-1
 

StayFrost04

New Member
Martin said:
By default HWiNFO should be showing the welcome dialog, where you can click Settings, but I suppose you disabled this prompt.
Manually you can disable Drive Scan by editing the HWiNFO64.INI file and change the HighestIdeAddress entry to:
HighestIdeAddress=-1
Thank you for the help. I changed HighestIdeAddress to -1 and now it works like a charm! Thanks a lot!
 

Martin

HWiNFO Author
Staff member
You're welcome.
Nevertheless, I'd interested in the HWiNFO Debug File of the crash on your system to analyze how can I fix this.
 

StayFrost04

New Member
Martin said:
You're welcome.
Nevertheless, I'd interested in the HWiNFO Debug File of the crash on your system to analyze how can I fix this.
I enabled the Safe Mode and then checked Debug Mode from Settings and ran the App. This time it didn't crash. It just took a very long time to load up. I have attached the debug file. 

P.S - If it helps - As I've said that this problem started occurring ever since I installed StoreMi. It's using a 120GB SSD to accelerate 1TB HDD along with using 2GB of my System Memory acting as Cache.
 

Attachments

Martin

HWiNFO Author
Staff member
Thanks. Yeah, I've seen a few issues with StoreMI and resolved some of them..
If you're able to reproduce the crash again, it would be great to capture that in DBG.
 

edwrdgrhm

New Member
*Apologies for the thread necro*

I had the same problem on my AMD system running Windows 10 and 18.50.16.01 WHQL chipset drivers for ASUS. Since I do not utilize StoreMI, I was able to resolve it by:
*Before starting, create a restore point in case*

-Going to the Device Manager
-Within IDE ATA/ATAPI controllers, there should be an entry for "AMD Virtualized AHCI Controller for StoreMI"
-Update that drive to "Standard SATA AHCI Controller" and restart
-HWInfo and default settings should start without crashing the system

I was able to find an AMD support article, but am not sure when it was last updated:
https://www.amd.com/en/support/kb/faq/pa-250
Based on that article, the AMD Virtualized AHCI Controller should not be installed on a Windows 10 system. It appears to have been installed by Windows Update, version 16.30.59.31 dated 7/10/2018, signed by Microsoft Windows Hardware Compatibility Publisher. Although I did not had problems running the AMD Virtualized AHCI Controller for StoreMI except with HWiNFO (and separate software issue, Crucial Storage Executive, Over Provisioning).
 
Top