HWiNFO 7.20 crashes on an Abit BE6-II

GL1zdA

Member
The Abit BE6-II was a popular 440BX motherboard. HWiNFO consistently crashes (everything hangs, no resposne to Ctrl+Alt+Delete) during PCI detection under 98 SE. Tried installing "Intel INF Update", but it doesn't help. SIV crashes in a similar way.
 

Attachments

  • HWiNFO32.DBG
    17.6 KB · Views: 3

Martin

HWiNFO Author
Staff member
Oh wait, this is Windows 9x, so that setting won't have an effect.
You might need to raise the "PCI Latency Timer" in BIOS.
 

GL1zdA

Member
Default on this board is 4 (apparently it's 4*8 CLKs). Increased to 8, 16 and maximum 31, it didn't help :(
 

GL1zdA

Member
Thanks, it went past PCI Bus scanning but hanged the PC on SMBus. After disabling SMBus support it worked! I assume Abit did something wrong on this board? I've used an ASUS P2B (also 440BX) motherboard previously, and HWiNFO32 worked without any problems there. If it helps, I'm attaching debug logs for SafeScan and SafeScan and SMBus suppot disabled.
 

Attachments

  • HWiNFO32.SafeScan.DBG
    28.5 KB · Views: 1
  • HWiNFO32.SafeScan.NoSMBus.DBG
    61.6 KB · Views: 1

GL1zdA

Member
This one works with SMBus enabled. Safe Scan is still required.

Additionally, here's a funny one. HWiNFO won't report much about the installed RAM sticks. It will even show the "empty" ones. CPUID does the same. But after I run AIDA64 (just run and close), both HWiNFO and CPUID start seeing the modules. Attaching screenshots. Yes, these are really PC-166 SDRAM modules, apparently some fancy overclocker modules made by PQI.
 

Attachments

  • ram-aida.png
    ram-aida.png
    33.6 KB · Views: 6
  • ram-hwinfo.png
    ram-hwinfo.png
    33 KB · Views: 6
  • ram-hwinfo-aida-augmented.png
    ram-hwinfo-aida-augmented.png
    48.7 KB · Views: 6

Martin

HWiNFO Author
Staff member
That looks like there's some explicit enabling of SPD access required. Please attach a Debug File of running before AIDA64 (without memory module details) and after running AIDA64.
 

GL1zdA

Member
It took me a while. It seems I was lucky the first few times I've launched AIDA on this motherboard, because now it's hanging 95% of the time at PCI devices detection. And if I disable AIDA's "low level PCI detection", it won't enable SPD information. Nevertheless, after like 30 reboots it finally managed to do the PCI detection without hanging, so here are the debug files.
 

Attachments

  • HWiNFO32.after.DBG
    47.4 KB · Views: 1
  • HWiNFO32.before.DBG
    45.8 KB · Views: 1
Last edited:

Martin

HWiNFO Author
Staff member
Hmm, this is really odd. I did exactly same as AIDA64 yet it doesn't help to "unblock" the SMBus Host. The controller doesn't seem to respond to commands by default.
 

GL1zdA

Member
I think it has something to do with the PCI safe scanning. It looks like I was just lucky with AIDA launching, because now it also locks up or blue screens on PCI detection most of the time. Disabling Low Level PCI detection in AIDA64 makes it launch every time, but it also won't report SPD information, so this step is somehow required.

I had only 2 cards installed: a Diamond Stealth 3D 2000 (ViRGE) and a 3Com Ethernet adapter. I've decided to replace the Diamond with another ViRGE, this time by ELSA, since I remember I've seen the Diamond in various readmes for games as causing problems sometimes. Now AIDA launches every time. Back to HWiNFO, I've disabled the Safe Search option hoping it will somehow trigger the SPD information, but no, HWiNFO still hangs on PCI detection on the ELSA. I've launched it 4 times with Safe Search and would always lock the PC.

I've removed the 3Com adapter, but it changed nothing, HWiNFO still hangs.

There's a HPT366 controller integrated on the motherboard, but I've disabled it since I don't use it. Enabling it changed nothing.

Moved the ViRGE into another slot - it changed nothing.

At this point, I'm out of ideas of what else I could change.
 

Martin

HWiNFO Author
Staff member
I think the problem is the mainboard and its PCI support. Could be some timing marginality or whatever.. Maybe the DOS version of HWiNFO would run better...
 
Top