Hwinfo crashes Asmedia Sata controller on Maximus VII Gene (and possibly others)


New Member
Hello to all,

Thanks for this great software which worked beautifully on almost all my boards (I had many...)

I would like to share the face that hwinfo makes the ASmedia Sata controller of my Maximus VII Gene board crash when reading HDD/SCSI. Either launching the software will freeze the pc, or it will make the drives attached to the ASMedia controller disappear, and the pc won't be able to reboot normally. I came to think my ASmedia controller was bad... JHowever, I noticed this bug to be present only when Hwinfo has been started.

I changed my power supply, I changed sata cable, I connected different drives to the Asmedia controller. The problem only appears when I start Hwinfo and have a drive attached to Asmedia. As soon as it loading half way, the drive disappears, and the pc won 't reboot normally (you can hear a click for the other drive in the shutting down screen of Windows 7).

When I had my SSD plugged to the Asmedia controller and tried to start hwinfo, I 'd get a frozen screen or bsod. With Hwmonitor or other software this issue does not come up

So I think something is wrong. On that machine I will not be able to use this soft ; life :)
On my Z97 Pro Gamer, it works fine (it has only one sata controller (Z97)) (except reporting Vcore3 wrong due to the lack of Vcore reading; Asus is the culprit).

This is a know issue of the ASMedia drivers and has been discussed a few times here.
Older ASMedia drivers seem to crash the system, while newer ones seem just to detach the drives. Perhaps an update from ASMedia will fix this, until then you'll need to disable Drive Scan in HWiNFO.
Thanks for letting me know about this known issue (sorry my quick search did not yield results).
It works like a charm now !!! Many thanks

Ps: Hwinfo is my favorite, was sad to let it go :D