HWiNFO no longer launches after changing setting


HWiNFO no longer launches after changing a couple settings: I unchecked the "current" column and enabled the "minimum". The first thing I noticed afterwards is the values got frozen altogether, so I decided to exit the program and try to relaunch it, but nothing. Restarted windows, still nothing. Whenever I try to launch, it appears for a couple seconds in task manager then disappears again.

These are the last lines of the dbg file:

51 ms
S #15
GPU_PMBus[T1] = 2A
GPU_PMBus[T2] = 1A
GPU_PMBus[VOUT] = 800
GPU_PMBus[VIN] = D980
GPU_PMBus[IIN] = D803
GPU_PMBus[IOUT] = F803
GPU_PMBus[POUT] = D830
GPU_PMBus[POUT] = D824
8 ms
S #16
1 ms
S #17
1 ms
S #18
Sensor Loop End
Sensor Disp Start
SD 0 ( 1: -1):"CPU [#0]: Intel Core i5-6600K"
SD 1 ( 1: 256)

Reinstalled on top and it launches again but half the sensor screen is glitching and jumping rows around, and all of the values are stuck on zero...

Ok, so further inspection indicates that the program starts screeching and throwing a tantrum only when disabling display of current value, as enabling it back immediately returns everything to normal. Which makes me wonder why I'm given the option to disable it in the first place.
So in conclusion I've now worked around the issue by pinching the column but it's merely that, the program still has something that needs to be looked at.
Last edited:
Are you running the latest HWiNFO version? There have been fixes recently for such situations.
Also if the issue persists, click "Restore Original Order" in sensor settings/layout or do a full "Reset Preferences" from main settings.
Thanks for your time. As I said previously, I've worked my way around the issue, but properly disabling the current value display will still effectively freeze the whole sensors screen.
I'm running v7.02-4430 and stock order, should I check the beta?
Beta v7.03-4470 does not quite solve the issue.
It's getting funkier, all the values are still stuck greyed on zero, except for those that branch into sub-values, which are too greyed/zero. These parent values do register valid minimum and maximum but are nonetheless zeroed at average.

edit: there's no hard freezing or launch issues, so it's progress.


  • HWiNFO64_HlCZG5xRB6.png
    10.5 KB · Views: 6
Looks like some mismatch in sensor configuration, try to click "Restore Original Order" in sensor settings - layout.
Then try a full "Reset Preferences" from main settings. If that won't help, I will need to see the full HWiNFO Debug File.
Full reset preferences, then clean wipe uninstall, then reinstall and reset again. Same issue, same behavior, same 7.03 beta. But yes I can send you the full file.