HWInfo Not Starting on Startup

HWinfo does not seem to ever start on Startup as asked.

I've tried re-enabling Auto Start:

I've verified the Task exists in Task Scheduler:

And the task is even running, yet HWinfo does not open on startup.
So if you run the task in Task Scheduler manually it starts?
Try to adjust the startup delay if that will help.
Running the task from Task Scheduler does not open Hwinfo even a few minutes into startup.
I've also verified in Task Manager that Hwinfo is not running at all.
Just to make sure I understand - if you right-click the task and select "Run" in Windows Task Scheduler, then nothing happens? If that's the case, there must be something wrong either with privileges (Admin) or its settings.
That is correct.
I changed the Task to not run with Highest Privileges, and it changed nothing. The .exe is not set to run as admin.
Is the user an Administrator and the "Run with highest privileges" option check in Task Scheduler?
This is a *BUG* (nothing to do with sfc).

I installed on a fresh win11 (fully updated), and can confirm the auto-start option do nothing.

The workaround is to create a shortcut and put it on: shell:startup (press window key+R).
I had same problem. I created a task, but app would not load on startup. I opened task Manager and edited properties/action.
The path was wrong. I changed the path and rebooted. Still not starting. so I uninstalled app, reinstalled it on Drive D. Changed path in Task Manager and voila! it works on reboot.
There was also a problem on one of the network machines, but there is the OS in such a state that it is time to demolish and re -set it - it will take less time than to correct the error accumulated over the years of work. The problem at first solved the problem in the simplest way - added a shortcut on HWiNFO64 in /All Users/Start Menu/Startup, but in fact it is necessary to repair a system planner of tasks - HWiNFO64 starts as its task. But personally, it is easier for me simple install nnCron (task sheduler like UNIX Cron) as daemon, rewrite all the tasks in crontab's and use it.