HWiNFO v6.30 released

Martin

HWiNFO Author
Staff member
HWiNFO v6.30 available.

Changes:
  • Added monitoring of SA, RoC, PCH and EDRAM power estimations on Intel Skylake and later CPUs.
  • Added ability to choose font type for tray icons.
  • Added option to show all fans including not spinning ones.
  • Improved support of VIA CNS.
  • Improved support of Intel Lakefield.
  • Improved support of several next-generation AMD CPUs, APUs and GPUs.
  • Added recognition of AMD A520 chipset.
  • Enhanced sensor monitoring on Intel Islay Canyon.
  • Added reporting of some missing extended CPU feature flags.
  • Enhanced sensor monitoring on ASRock A520 series.
  • Enhanced sensor monitoring on MSI A520 series.
  • Improved support of legacy Trident graphics cards.
  • Added Dark Mode support. Requires Windows 10 Dark Mode for apps enabled.
  • Enhanced NVIDIA Ampere support.
  • Improved reporting of GPU PCIe current link speed.
  • Enhanced sensor monitoring on GIGABYTE A520 series.
  • Enhanced sensor monitoring on ASUS A520 series.
 

uhlik

New Member
Is there a way to enable/disable Dark Mode on demand? It looks ugly side by side with other Win32 apps monitoring in Windows dark mode and I didn't found a way to override.

1598536406638.png
 

Martin

HWiNFO Author
Staff member
I will add a switch to force disable Dark Mode in the next build.
Yet wondering why you have Dark Mode enabled in Windows and blaming HWiNFO for supporting it when you run apps that don't do so.
 

uhlik

New Member
I restored v6.28 exe and ini file but color scheme for graphs is still dark. It looks like dark mode is overwriting GraphColorBkgd value. It should use separate registry values for dark and light mode because if I want to use both modes I want to set another set of colors for both modes.

Before upgrade / After downgrade:

1598537332532.png 1598537110405.png
 

Martin

HWiNFO Author
Staff member
I restored v6.28 exe and ini file but color scheme for graphs is still dark. It looks like dark mode is overwriting GraphColorBkgd value. It should use separate registry values for dark and light mode because if I want to use both modes I want to set another set of colors for both modes.

Before upgrade / After downgrade:

View attachment 5089 View attachment 5087
Shall be fixed in the next build.
 
Top