Hwinfo32 and msi afterburner

zook666

Member
Hi
Installed hwinfo32 v3.70-1153 today, when i run it msi afterburner crach?
No problem with previous verisions of hwinfo32.
 

Martin

HWiNFO Author
Staff member
What did crash, application or the system?
Please attach the HWiNFO32 Debug File after the crash, so I can analyse it.

zook666 said:
Hi
Installed hwinfo32 v3.70-1153 today, when i run it msi afterburner crach?
No problem with previous verisions of hwinfo32.
 

Martin

HWiNFO Author
Staff member
I suppose this is an issue of MSI Afterburner, since it doesn't use proper synchronization objects that are currently used by most monitoring applications.
HWiNFO32 with several other applications have recently moved to using Global namespace for these mutexes (to synchronize access to hardware when running concurrently), but some applications are still behind.
You can check this page for a list of applications: <!-- m --><a class="postlink" href="http://www.techpowerup.com/wiki/doku.php/systool/mutexes_to_avoid_collisions">http://www.techpowerup.com/wiki/doku.ph ... collisions</a><!-- m -->
According to information there, MSI Afterburner should use Global objects from version 2.1.0 beta 5, so I would suggest to get that version or a later and try it.
 

Martin

HWiNFO Author
Staff member
Because HWiNFO32 switched to Global namespace as other tools did as well.
Use the mentioned version of Afterburner or later and let me know if it works.
zook666 said:
HWiNFO32_3.68.1130 works with afterburner but not later versions?
 

zook666

Member
tryd afterburner 2.1.0 beta 5 and 7, it just work with hwinfo 3.68 when i try it with 3.70 afterburner crash.
 

Martin

HWiNFO Author
Staff member
Hm.. then who's the bad guy - HWiNFO32 or Afterburner? Since HWiNFO32 wins this fight :D, I'd say the Afterburner needs a fix.
zook666 said:
tryd afterburner 2.1.0 beta 5 and 7, it just work with hwinfo 3.68 when i try it with 3.70 afterburner crash.
 

zook666

Member
its when i open sensors in hwinfo then afterburner crash, and its just 3.70. hmm something in 3.7 makes it crash xD
 

Martin

HWiNFO Author
Staff member
But since it's Afterburner which crashes and HWiNFO32 survives, it's impossible for me to find why the other crashes. That needs to be fixed, but on other side.
 
Top