HWiNFO64 crashed during Install and nearly broke System


New Member
I bought a new second Harddrive for my Laptop, a HGST Travelstar 7K100. Since it´s been over 3 years since i bought the Laptop (Alienware M17xr2, I also reinstalled Win7 from scratch on the original first HDD.

After everything was updated I started reinstalling software, including HWiNFO64. But it crashed right during the install process and also crashed the system. Something about IDE and/or SATA 2 was written in the install window when it crashed, but i didnt write it down because I didnt know how bad that crash was going to be.

I had to shut the Laptop down, but the system couldnt reboot, no Windows logo or anything, just a black screen.
Even the Repair System Option on the Win7 Install Disk (thank god I made a DVD Image from the digital download) failed like 3 times with an unspecified error. I checked the .log file, and the only result was either no errors found, or the unspecified mentioned above.
After that I found the System Restore option and used a restore point from 3 days earlier, which finally worked. Nevertheless I reinstalled all HDD drivers before I had the feeling everything was working properly again.

Soooo, since the only thing that changed is that new harddrive, its pretty clear what the problem is. There are no log files since the install failed, so any idea how to figure out what exactly the problem was ?

And how to fix it, I really want a fan control pretty bad, since the CPU fans are incredibly noisy in the original setup.
I'm sorry, but since there are no traces of the crash, it's impossible for me to determine exactly what happened.
I'm also wondering that the crash happened during installing of HWiNFO64, since this process is fairly simple and in this phase no hardware access is performed. Are you sure you haven't launched HWiNFO after the install ?
Anyway, to check more precisely what happened, I'd need to recreate the crash while running HWiNFO with Debug Mode enabled and then submit the produced DBG file.
Thanks for the quick reply.
Well it could be, since I had the installation process on a 2nd screen and was browsing the web while running the installation.
And the message about "SATA 2 something" I remember would also make more sense popping up during the first system scan from HWiNFO.

Would it be possible that while it was reading the driver file, for some reason crashed and combined with me turning the system off the driver file got corrupted, causing all the trouble afterwards ?

So since I have to install it again to find out why it didnt work, how can I launch it in debug mode to get that debug-file ?
You'll need to install it again, or you can just run the Portable version which doesn't require install.
Then right after launching, don't press Run, but click Settings and in the Safety tab enable "Debug Mode". Then continue as usual...
I just ran the portable version and also installed the regular one afterwards without any problems.

When I started the Sensor scan for the first time though, it did stop again, while scanning for "disk activity #3".
Which is my external HDD - and it powers itself down after a while if not in use - so the scanner got stuck waiting for the HDD to respond which it didnt it seems. I unplugged the whole USB hub and the scan finished without another problem. I ran the sensor scan again with the HDD turned on and it worked fine, now it doesnt even bother when its turned off again.

What was the problem the first time I dont know, since I had no external devices plugged in back then.

Everything seems to be working fine right now, so thanks for your input :)
Tilisun said:
My laptop Alienware m17 R4 and it's just one of the problems with Jakiro. Help me please!!!

Sorry, but you need to be more specific about what kind of problems are there.
When I installed the program HWiNFO64 v4.35 system of my laptop hangs when not run anymore and then press the shutdown button crashes, but off-screen keyboard backlight, speaker lights still work. If HWiNFO program to run automatically when to Win load is not being released immediately and while running, sometimes even system crashes always win. It was stopped when the load PCI Bus.... or something and not run to another.
But i disable the "Wake disabled GPUs" option in HWiNFO.

This file HWiNFO64.DBG

I installed HWiNFO64 with Gadgets to win but only when running HWiNFO64 also Gadgets not run and do not know if it HWiNFO conflicting Gadgets not???


  • HWiNFO64.rar
    42.7 KB · Views: 1
I don't see any problems according to the DBG file, no crash.. Was that DBG generated during the crash you described ?
Is this really hanging, or just takes too long to finish ?
I assume you're using the Autostart in HWiNFO. You might try to raise the startup delay of the HWiNFO task in Windows Task Scheduler to see if that maybe helps.
Martin said:
Is this really hanging, or just takes too long to finish ?
I assume you're using the Autostart in HWiNFO. You might try to raise the startup delay of the HWiNFO task in Windows Task Scheduler to see if that maybe helps.

Yes this is takes too long to finish but how to complete the fastest?
That depends on in which phase it takes too long. If it's the "Analyzing devices..." the delay in Task Scheduler might help.
But now I don't understand, first you said that there was a crash, now it's something else? I need to approach each issue separate.
That's not the error but when HWiNFO load "Analyzing devices ..." for a long time, about 10 minutes to complete. How to run faster???
I already told you what to try:
open Control Panel -> System and Security -> Administrative Tools -> Task Scheduler
Choose "Task Scheduler Library" and locate the HWiNFO task. Then double-click to open.
Select the Triggers tab -> "At log on" and click Edit.
Raise the "Delay task for" to 30 seconds and see if that helps. If not, try to raise this even more.
Hi i have downloaded the HWinfo64 for my lappy but it shuts down abruptly. need help.


  • Untitled.png
    343.9 KB · Views: 2
This could be a problem in GPU OpenCL driver, an update might fix that. Which GPU do you have?
As a workaround, you might try to disable the "Wake disabled GPUs" option.