HWiNFO64 Intermittent Functionality in W10 Bld 19043


I have an odd problem with HWiNFO64 (currently up to 7.20) under Windows 10 (Version 10.0.19043 Build 19043)

When running the app normally or as administrator, the app shows up in the Task Manager, but does not show up in the system tray. I'm using it to feed Rainmeter and the Rainmeter CPU meter shows all zeroes when the app is running but nothing when it is not. The GPU meter acts like it doesn't see the app at all. So it appears that the Rainmeter is at least aware that the app is running at some level.

Oddly, when I get an 'update is available' pop-up on screen from the app, all of the app windows open up, the app shows in the system tray, and the Rainmeter meters all show data. It will run like this until I restart the PC at which time the previous issue returns.


  • HWiNFO64 Issue.png
    HWiNFO64 Issue.png
    108.8 KB · Views: 7
How do you have HWiNFO configured - automatic start with Windows, Show Sensors on Startup, etc. ?
Can you post the HWiNFO Debug File capturing the situation when nothing shows up? You'll need to start HWiNFO in Debug Mode, then after it's started kill it and grab the HWiNFO64.DBG file it created.
I have it configured to run at startup, but it also happens if I run it manually. I do have it set to run as Admin, but get the same results either way.

//edit: Here is the .ini contents
[Settings] MinimalizeSensors=1 MinimalizeSensorsClose=1 ShowWelcomeAndProgress=0 Autorun=1 AutoUpdateBetaDisable=1 DebugMode=0


  • HWiNFO64.DBG
    864.4 KB · Views: 1
This is odd as there seems to be something blocking HWiNFO from performing some WMI queries to determine drive information.
Try to disable Drive Scan in HWiNFO if that will help.
You don't need to modify the INI. This is in the main settings of HWiNFO - Safety - Drive Scan
I see that you have some virtualization enabled and a "Microsoft Virtual Drive Enumerator" device. Wondering whether this might be causing the blockage...
The problem being that I can't access the main settings. All I can get to is the INI until the next update comes along to make everything visible again for a bit.

What's odd is that all those things are enabled when the windows do pop-up on update notification. Is there something in the update notifier that may be overriding whatever's causing the issue?
Then put the following line into the INI file:

I'm not aware of any specific that the update notification would do. Probably it's some indirect effect...
That worked. And once the app comes up I can plug it back in and everything stays running.

For specifics, it's a USB XBOX 360 type controller, IZD Tech Model ZD-T408 connected to an external, powered USB hub. Not sure if the issue would be common to any XBOX 360 controller or specific to this model. Do you need me to do anything else to help narrow down exactly what's going on?
Further info.

If I unplug it with the app running everything comes without even needing to restart the app. I also removed the HighestIdeAddress entry from the INI and it's still working as intended.
We've seen such issues with the Xbox 360 controller - it's causing the standard USB enumeration to hang. Unfortunately I don't know how to fix this yet.