hwinfo64 sensor only crash


Hi, I have a problem starting hwinfo64 with the sensors only option ticked, it starts reading the system and then nothing. If I open task manager it shows the hwinfo64 is using one of the eight cores continuously a max speed, the only way to stop this is to end the processin task manager. On reading through some of the other users bug reports with problems similar to mine, i tried some of the recommendations (turning of drive scan and host etc.), none of these made any difference, always the same problem. I also found that if I started the program without the sensor option ticked, the program ran fine untill I switched the monitoring-sensor status on, then it starts to read the system, then freezes the program with "hwinfo64 is not responding" and I have to use task manager to stop hwinfo64 from using the one core at max speed again.
This all started when I updated from version 4.64-2530 to v5.20-2800. The older version was working perfectly a few minutes before the update, there were no driver updates between using one version to the next (windows updates is on manual). I have for the moment uninstalled v5.20-2800, run ccleaner reg cleaner and installed v5.02-2575 and all is running great again.
I will when I have time re-install v5.20-2800 and get a debug file for you (I'm on my way to work at the mo sending this from my phone.

Windows 7 ulimate 64
Fx 8350
Asus m5a97 evo r2.0
Sapphire vapor-x r9 280x oc
8GB crucial ballistix tactical tracer
Kingston 128GB ssd
Sandisk 256GB ssd
WDC 1TB hdd
Seagate barracuda 750GB
I will need the DBG file capturing the problem, only then I can provide more insight.
Hi, finally got time to reinstall HWinfo64 5.20-2800 and get a debug file for you.
I have attached the report file and done 2 dbg files, 1 is sensor only and the other is running the whole program and then selecting monitoring>sensor status, both have the same effect where as the program stops responding



Martin said:
I will need the DBG file capturing the problem, only then I can provide more insight.

I see there is a problem with asmedia drivers but all the other Hwinfo64 versions work with those same drivers, as I said in my first post when I reverted back to v5.02 it worked perfectly
Thank you for the data. It tells me something, but unfortunately the existing Debug File doesn't provide enough information for me to identify the problem.
So I have made some extensions that might help me. Please run this build: www.hwinfo.com/beta/hw64_521_2802.zip
and create a new DBG file with sensors (it doesn't matter if you run in Sensors-only, or open them afterwards).
Then I hope to be able to understand the problem.
That was different less use of the cpu cores and spread over all eight

sorry had to run it twice I couldn't upload it (too large)



Fantastic, that seems to have cracked it, it works great as far as I can see.

Thank for your help and a great program

Kind Regards

Not that I would fully understand but what was the problem with?

Don't worry if you haven't got time to answer
Thanks for the feedback.
The problem was when I added monitoring of Pagefile usage in the latest version. However in case of multiple page files (you actually have 3) it didn't work properly and entered an endless loop while trying to read usage of multiple page files.