Request to hide units, commas, extra spacing

class101

New Member
Martin said:
OK, I'll add aligning of usage values for RTSS, but in a slightly different way. It will be automatic, but won't prefix the value with a 0, but an empty space instead. So you'll get for example:
54.3 %
_6.2 %
"_" is an empty space character.
That will be available in the next release.

If you don't want to display the commas as separators, you can do this with the current version - just configure HWiNFO to place values at the same column. For example:
Core 0, Thread 0 Usage: Line n, Column 1
Core 0, Thread 1 Usage: Line n, Column 1
Core 0 Temperature: Line n, Column 1

Sorry to bump an old thread but did you added it Martin ?

Because yet in HWiNFO 4.44-2300 I'm still getting

1 space = 0
2 space = 00
3 space = 000

When I would have expected it to be

3 space = 0
3 space = 00
3 space = 000

The downside currently, when placing the OSD on the upper left corner, the whole line moves when the GPU ticks from 10-99 to 100% (a lot)

If placing the OSD on the upper right corner, all the lines are moving left (probably the left align)

I have tried to put a " " or "_" before the symbol but it did nothing, the space is not replaced and with _ no space is shown

Also tried with values in the same column or different columns, it did not made it.

Any news about this =)

//edit: Just tried on v4.45-2313, same issue

//edit2: Found a way to mitigate effect I was using "GPU D3D Usage" but using "GPU Core Clock" seems better as it never (or rarely) reach 100 but 99 and also rarely goes under 10%, but still I would appreciate to have this fixed if hwinfo is supposed to pad
 

Martin

HWiNFO Author
Staff member
Yes, I have added that in the past, but not for the 100% value. Means that values 0-9% are prefixed with one space, but 10-99 are not.
I'll fix this in the next build, so that 0-9% are prefixed with 2 spaces and 10-99% with one.
 

class101

New Member
Martin said:
Yes, I have added that in the past, but not for the 100% value. Means that values 0-9% are prefixed with one space, but 10-99 are not.
I'll fix this in the next build, so that 0-9% are prefixed with 2 spaces and 10-99% with one.

Awesome, if I have a suggestion I have done that in the past in Lua wow addon for programmatically determinate the padding size instead of relaying on a known string length

length of max value - length of actual value = number of space required

Like imagine someone sets 4 decimal

a % max is 100.0000

actual value 1.5500

8 - 6 = 2 space

if you base it on a fixed length 3 or 2 or 1 like you did you miss all the case of the numbers with decimals, and fixing them all is a boring job heh
 

online123

New Member
In RTSS:

A) How to remove space between vaule and unit?

It is -> CPU 20 % 2500 mhz
I want -> CPU 20% 2500mhz

B) How to increase space between the values (or add separator)?
CPU "(more space)" 20 % "(more space)" 2500 mhz
or
CPU - 20 % - 2500 mhz

Thanks.
 
Last edited:

Martin

HWiNFO Author
Staff member
A) is currently not possible
B) is possible to a certain degree by renaming the sensor
 
Last edited:

madvillain

Member
Old thread but -- @Martin
A) is currently not possible
B) is possible to a certain degree by renaming the sensor

Is A till impossible? It's killing me that I can't have the GPU TDP show as 30%, I was able to modify the spaces using the formatting but since the % is what I am trying to move, it throws off everything. I presume that's why it was and may still be impossible to move the % closer to the value? Photo attached so you can also share my annoyance !! Kidding. I love your product, proud Pro license holder. Keep up the great work.

 

Martin

HWiNFO Author
Staff member
Old thread but -- @Martin


Is A till impossible? It's killing me that I can't have the GPU TDP show as 30%, I was able to modify the spaces using the formatting but since the % is what I am trying to move, it throws off everything. I presume that's why it was and may still be impossible to move the % closer to the value? Photo attached so you can also share my annoyance !! Kidding. I love your product, proud Pro license holder. Keep up the great work.


Currently it's not possible but I can easily make a modification that if you enable "Units in superscript" it won't insert the space.
 

madvillain

Member
Currently it's not possible but I can easily make a modification that if you enable "Units in superscript" it won't insert the space.
Cheers!! That would be amazing and make many others who suffer from self diagnosed OCD sleep much better at night. This change actually would allow stream deck users like myself to avoid the special formatting to keep the degree symbol⁰ and frequency (mhz) attached without a space. Currently I use "%0f.3"(suffix here) as a sort of hack but it won't work with % as we mentioned.
 
Top