Seagate USB 3.0 disk hanging after HWInfo is run



PC is MSI Cubi with Intel Pentium 3805U CPU and Intel integrated USB 3.0 controller (MSI Cubi it has 4x Intel USB 3.0 ports). OS is Windows 10 x64 Fall Creators Update.
I have Seagate Expansion Desktop 2TB USB 3.0 drive (model STBV2000200) connected to it. I bought the case empty/disassembled and installed own WD 3TB Greeen disk in it. It works perfectly but...

Every time I run HWInfo64 this USB case 'hangs'. Drive letter is still visible but you can no longer browse files, any attempt to enter directory takes a lot of time, then times out. The blue light on top of the USB case blinks constantly as if there was some constant activitiy (but thete's nothing going on). If you try to reboot Windows, it is taking forever, you must hard reset PC to do it but then you have the same problem.

The only way to restore normal operation of USB case is to power cycle it (unplug/replug power supply connector).

Any idea why this is happening ?

Is the USB disk really connected via Intel USB controller, or is it perhaps an ASMedia USB controller ?
I'm aware about this ASMedia issue but it is not connected via ASMedia controller. This mini-PC ( has no additional USB controllers except the one built into the Intel chipset and 4 ports are available outside (no need to post a screenshot from device manager here, trust me, in Device Manager under USB controllers there's only Intel USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)).

It seems like something that HWInfo is doing during device scan is causing Seagate USB controller to hang.

If it helps:
In Device Manager this USB case is visible under Disks as "Seagate Expansion Disk SCSI Disk Device" and under Storage Controllers as "Mass Storage Device SCSI (UAS) Connected via USB" (sorry, I'm translting this from Polish, might not be 100% accurate).
I haven't tried this before but indeed disabling drive scan 'fixes' the problem (or just doesn't trigger it).
This was behaving like this from the beggining (at least a year, ever since I have this PVR setup with MSI Cubi and external Seagate case as storage for TV recordings). I just haven't had an occasion to report it.
That means some of the standard queries HWiNFO uses to check drives is probably causing problems with the Seagate firmware or its USB bridge.
Perhaps if you'd enable Drive Scan again and send me the HWiNFO Debug File of the system I could check in more detail and make sure to add a workaround not to scan this device.
Thanks. I have checked the details, but unfortunately cannot see anything suspicious that might be causing this problem :(
All standard queries issued to that device work..
Possibly this is because I'm using WD drive in Seagate enclosure. Anyway, the solution with disabling Drive Scan is sufficient for me. Thanks for help.
Try to check the USB connection and the contact in the power supply circuit - in this model, stasctics often fail connectors. It looks like it is from a number of Seagate products, together with the purchase of the HDD of the Samsung division of the SpinPoint family, which did not have a high build quality and good mechanics with excellent electronics. Samsung as a manufacturer specializes in the production of semiconductors starting with memory chips and ending with processors (it was released by the DEC Alpha AXP 21064 - 21264 CPU, the 21064A series, the DEC Alpha AXP 21068 and the DEC Alpha AXP 21164, besides Intel, and from 21064 it copied the FPU for the CPU family Pentium / Pentium PRO), but the mechanics order from subcontractors and there as lucky - can break down at once, can work for a while, but is usually smaller than products specializing in precision mechanics manufacturers. All HDD Samsung belonged to the budget series of their classes and there they economized on everything.