Sensor alerts go off only after opening the software



There are some alerts that only trigger when the software GUI is opened.

In case the software is minimized to taskbar; it saves the trigger state, then only once I double-click the HWinfo icon, all alerts triggers at once.

So far, this only happens for WATT (power) and FAN speed % sensor alerts.

Any idea what's going on?

Thank you!
I'm sorry but I can't reproduce such behavior. I tried to set several different programs and they all open as expected even when HWiNFO is minimized.
Which program are you trying to start and what are the other settings?
I see. I'm running a simple .bat file, which also runs smoothly on other sensor alerts.

these are the settings:


Is it possible that those sensors don't reach the threshold when HWiNFO is minimized? You should be able to verify this by inspecting the Alert log file.
Nope, they do reach it for sure. I disconnect the fans, so they should go to 0% and triggers the alert.
Even after one hour, they won't trigger till I open the GUI of HWI, and you can see all of them trigger at once (several CMD windows open up at once).

When I think about it now, it might have something to do with triggers set to below a value ('<') - those are the power and fan alerts I need...
Hi Martin, I've created a short video showing the CMD windows pop all together, right after opening Sensors GUI. The actual trigger was ~50 mins before that.

Sorry, so far I have no idea why this is happening. Can you try (just for a test) to run some other application for those values? Just to see if that makes any difference..
No worries. I tried with an exe file instead of bat - still get the same results.
Happens only when a trigger is set to 'below' value (opposite to 'above' value, which works fine).
I found a workaround; in settings, I check both "show sensors on startup" and "minimize sensors on startup". Since the problem showed up only when the software is minimized to taskbar - this workaround works well, and keeps 'below certain value' triggers to execute as expected.

Thought this would help someone with the same issues.
Thanks for the heads up. This is interesting and I'm still scratching my head why it behaves different, but I still wasn't able to reproduce this...