Thunderbolt e-GPU shown as PCI-e 1.1 ×4


New Member
Hi, I'm Xutao ZHENG from China. I found a weird thing (I'm not sure whether it is a bug).

I have a external GPU connected to my thunderbolt dock. The GPU-Z says it is running on PCI-e 1.1 ×4 when idle and PCI-e 3.0 ×4 when rendering something (as shown below).

屏幕截图 2023-03-08 205316.png 屏幕截图 2023-03-08 205220.png

However, the HWiNFO64 says it always runs at PCI-e 1.1 ×4, whether rendering or not. I restart HWiNFO64 while rendering but it still shows PCI-e 1.1 ×4.

屏幕截图 2023-03-08 211121.png

Then I tried the third party, the AIDA64 GPGPU test. The memory read and memory write results seems that PCI-e 3.0 ×4 (4 GByte/s theoretically) is correct.

屏幕截图 2023-03-08 211151.png

Can you tell me the exact PCI-e version in my case? And why these softwares show different results? Thanks a lot.



  • HWiNFO64.DBG
    1.3 MB · Views: 1
Information in the main window of HWiNFO doesn't update real-time. To monitor actual/changing parameters open the Sensors window.
Hi, Martin, thanks for your reply.

I noticed that so I tried to
① restart HWiNFO64 while running GPU-Z render test, but it still shows PCIe 1.1
② check the sensors window. I didn't find PCIe version but the PCIe speed is 2.5 GT/s (speed of PCIe 1.1)
So it still confused me.
屏幕截图 2023-03-10 094837.png
If the PCIe device (GPU) is connected via multiple PCIe ports/bridges HWiNFO reports the current minimum PCIe link speed of each port in its path.