Unable to start 7.60


I've recently switched from an Intel platform to an AMD one and has been experiencing some odd issues where HWiNFO64 either won't start or starts normally and then suddenly crashes and refuses to restart.

I've attached the debug file since I can't start it right now to generate the report.

The motherboard is on the latest UEFI/BIOS and all the drivers have been installed and updated, so it should be fine. The CPU isn't running any overclock, just the EXPO profile from the RAM.

Let me know if you need anything else. :)


  • HWiNFO64.DBG
    248 bytes · Views: 1
Unfortunately the attached Debug File is truncated as you have run HWiNFO again to disable Debug Mode that that has overwritten the previous content.
First try to completely "Reset Preferences" in HWiNFO. If that won't help, please attach a new full Debug File.
I can't start HWiNFO to reset anything.
But I deleted the debug file, enabled the debug mode in the ini file and tried starting hwinfo again.
The new file looks similar to me, but maybe it tells you something.

EDIT: I also tried clearing the ini file leaving only:

Same result.


  • HWiNFO64.DBG
    248 bytes · Views: 2
Sorry, still the same 248 bytes long file.
Open Registry Editor (regedit) and delete the following key: HKEY_CURRENT_USER\Software\HWiNFO64
I tried removing the registry key you specified.
I also tried moving the executables to a new drive to make sure it didn't load any config file, or tried to read the license file.
I then also tried with the settings file that only has debugmode in it and it still doesn't run.

All the cases above leave the same truncated dbg file.

Funnily enough, the 32-bit executable runs just fine, even if it does show the alerts that I'm on a 64-bit system..
For good measure I tried downloading the 7.61_5180 beta portable and ran that, no license, only debug config, removed the regedit entry before.
It produces the same dbg file.
Make sure that Debug Mode is enabled and run HWiNFO64. When it crashes, grab the DBG file without attempting to start HWiNFO again.
That file captures only the closing of HWiNFO, no start. Maybe you're looking at a different file?
I found a screen recorder to show you the steps, please excuse the watermark. ;)
Due to the file extension restriction on the forum I had to 7zip the video, but it's an MP4 of the specific steps, to show you exactly how I get to that file.

EDIT: Video archive removed because it contained personal information. :)
Last edited:
Is there a way to get the debug/logging to go into the terminal instead?
In that case it can't be overwritten by any subsequent actions unless the program prints backspaces.
Well, I have to admit that this is a mystery.. It behaves really strange.
Maybe because the Dropbox folder is handled differently? Try to start from a completely different folder or try to install the Installer package of HWiNFO.
Are you maybe running some anti-cheat or anti-malware tools that might be blocking HWiNFO?
Mhmm good one, those can be a bit sporadic in how they do things.
I have BitDefender running, but disabling all the features (so many checkboxes) didn't change anything.

One of the odd things is that usually, a restart will solve it, but not always.
Haven't seen such issue yet. Odd is also that the Debug File is not created properly - it behaves as if initially the file was stored somewhere else and then when it closes a different one is made.
Or - something in the system is forcefully restarting and terminating HWiNFO.
I tried looking through the Windows Event viewer, didn't really find anything, the only relevant parts is the UAC approval entries.
I can try running it in debug mode from next reboot and see if something interesting comes of it?