Check in Task Manager if there aren't some tasks loading the disk high. Perhaps some Windows update in progress?
OK, so regarding those WHEA Errors, they should be valid. Check under Windows Logs -> System, there should be respective entries with "WHEA-Logger" Source providing more details.
No, it was nothing loading the gpu, if i tried to even delet a 200mb files the HDD got maximum charge and then not even 1mb/S
What is the S.M.A.R.T. section of the disk showing in sensors?
And also what are you seeing in TaskManager? Processes tab, Disk activity %. Is there any processe that uses the disk alot?
I've already runned a test in S.M.A.R.T it says everything is good, and fuck, i forgot to check if something was using to much disk, anyway, i've already formatted the HDD and still doesnt work, i had to unplugg it because my windows didn't boot, what means, i can't connect the hard drive to check what process was using that disk
Just for future OS installs...
Always remember when you're installing windows you "must" disconect every other secondary drives you may have. Otherwise windows is "bonding" with them during installation and you cant disconnect them without issues.
Well, its the opposite, if i have it connected i cant boot windows, if i dissconect it i can play and use windows without any trouble, i think i am gonna buy a new hard drive, but first i know someone, he fixed my evga600w when it literally burned, so thanks for your help, the problem was something in the HDD, something that cant be fixed formatting it.
Hello, i realize i have this errors, and i had to format my entire pc, SSD AND HDD, i deleted everything, because my pc wasn't booting and i had blue screen, so i started to play with my pc when i deleted everything on it , and i realized i had this errors again, and please, i need that somebody explains me how to fix them, its so annoying, please, i need help.

View attachment 5254
Hey Shuletah. I just ran into this WHEA Event ID 20 Error on my new system. Everything was running ok until I started tweaking around with settings in BIOS. I narrowed it down, at least on my pc, being the infinity fabric acting up once I got it past 1800. It works perfectly fine at 1800 with my Ram going 1800 (ddr4 3600). At first I thought it might be my Ram that's the problem because I clocked the Ram and the Infinity fabric to run at 1933 (ddr4 3866). Everything seemed fine and ran without hiccups for a couple days, I even ran Memtester to check for errors and came out fine with no errors. And then today I started getting random shutdowns. I did a bunch of stuff to troubleshoot but eventually reset my bios settings and then didn't see any more errors in HWiNFO. After that I played with Ram and Infinity fabric timings and found out that it's stable without errors up to 1800 for the Infinity fabric even if I clock my ram higher. Eventually I got everything in my bios to be same as when the crashes were happening except one thing which was the Infinity fabric frequency. I think Infinity fabric will clock differently with different ram kits and how many sticks you have, and depending on that will depend on it's stability.

This is a long post to hopefully help you and others, or at least give some insight into how you can pinpoint your issue. Since you're running ryzen too maybe it's something to do with the infinity fabric on yours as well but I can't say for certain as I've seen intel guys have this WHEA even ID 20 as well (altho they were running multi-cpu motherboards).

I'm running a ryzen 5900x with 4x16 3600 crucial ballistix.

As for your Ram being single Rank, don't worry about that, Single/Dual Rank is different than Single/Dual Channel, and from the picture you posted of your Ram it looks like it's installed correctly.
Last edited:
Sorry to see you're having problems.
You say 'Edit: i just updated bios a week ago'.
If you didn't have a good reason for updating the bios, I would consider reinstalling the earlier version.
Two sticks of mismatched ram - that also could be your problem (or maybe you have more than one problem).
If you ordered a matched-pair kit from the store then you should consider requesting what you ordered.
Kind regards
Last edited:
useaname is right, the 2 different ram types could be a contributing factor. I just quickly glanced at it and didn't notice that they're both different.
hey, i am so sorry i didn't see your message before, my problem was the HDD as i said, i fixed it changing the SATA cable