Won't Auto-Launch under User Account

Steve

New Member
Background:
Windows 10-64 Pro.
I've enabled the 'Admin' account.
I created a non-admin User account that I use regularly.
I have tried installing HWiNFO under each account.
Problem:
In either case, I can't get it to auto-launch with Windows or the User account.
I have tried:
1) the HWiNFO's settings,
2) User account Startup folder/Task Manager Startup, and
3) Task Scheduler based on Windows or the User account.
Any suggestions?
Thank you.

BTW I LOVE this program!
I am impressed at the simple yet extensive functionality and attention to detail.
I appreciate the time and care many (most?) of you have put into it.
Thank you.
 

Martin

HWiNFO Author
Staff member
HWiNFO requires administrative rights.
You will need to modify the HWiNFO task in Windows Task Scheduler to run with highest privileges or change the account under which it's run.
 

Steve

New Member
Hi Martin,
I appreciate your helpful reply, thank you.
It confirms I've been on the right track.
However, I'd actually taken those steps.
Feel free to check attachments 1-4 but note I've 'switch' the names of the Admin and Guest accounts.
More Info:
Task Manager shows the process running upon Admin or User login.
However, it isn't on the TaskBar or in the System Tray under either account.
To test I set a very low CPU alert but it isn't triggered until I manually launch the app, again, under either account.
Then I tied leaving it enabled in Task Manager and putting it back into the Admin and User StartUp folders.
Then under the Admin account, I get the Run window (attachment 5) but it still isn't fully auto-launching.
Under the User account still just the process without TaskBar or System Tray.
Any other suggestions?
 

Attachments

  • 1.png
    1.png
    24.5 KB · Views: 3
  • 2.png
    2.png
    14.8 KB · Views: 3
  • 3.png
    3.png
    25.9 KB · Views: 3
  • 4.png
    4.png
    23.5 KB · Views: 2
  • 5.png
    5.png
    9.8 KB · Views: 2

Martin

HWiNFO Author
Staff member
I think that applications run with "Run whether user is logged on or not" don't have access to the GUI, similar to a service.
 

Steve

New Member
Again, I appreciate your helpful reply, thank you.
I switched to Run only when user is logged on (attachment 6).
However, then the Run window doesn't come up anymore.
Maybe it should run with some other type of user like System or something?
Any other suggestions?
 

Attachments

  • 6.png
    6.png
    23.5 KB · Views: 3
Top