AMD 980G Chipset detected as 880G

T.Frank

Member
Hi,

i've the problem that my mainboard has an AMD Series 9 - 980G chipset. But the HWiNFO32 reads an AMD Series 8 - 880G chipset. I know that these two chipsets are very similar.

Do you have an idea how i can fix this, or is this an bug of your program?

Thank
Tobias
 

Martin

HWiNFO Author
Staff member
Could you please attach the HWiNFO Report File and Debug File, so I can analyze it ?
 

Martin

HWiNFO Author
Staff member
I'm sorry, but the 880G seems nearly identical to 980G and I haven't found a way how to distinguish them.
So I'll at least make it to report "AMD 880G/980G".
 

T.Frank

Member
Martin said:
I'm sorry, but the 880G seems nearly identical to 980G and I haven't found a way how to distinguish them.
So I'll at least make it to report "AMD 880G/980G".
Thanks for your reply. The difference of them to distinguish them should be the southbridge! Is this helpful for you?
 

Martin

HWiNFO Author
Staff member
But the SB on your machine was identified as SB810/SB850, is that correct ? As far as I know, the 880G uses the SB810/SB850 too.
 

T.Frank

Member
I got an clarification from AMD with which you can identifie the 980G chipset, i hope this helps you:
AMD BIOS Test Suite tools shows combination of RS880 northbridge and SB950 southbridge
So it seems to me that the SB also is not correct identified.
 

Martin

HWiNFO Author
Staff member
I'm sorry, but I haven't found a reliable way how to distinguish SB850 from SB950 yet.
The method I'm currently using doesn't seem to work in this case... :(
 

T.Frank

Member
OK, so if i understand it right, this is a bug of your software, and you will fix this in the next release?
So in the future you will show both chipset as one as "AMD 880G/980G"?
 

Martin

HWiNFO Author
Staff member
You can call it as a bug in HWiNFO :) But the truth is that the manufacturer (AMD) doesn't give out information how to distinguish 880G from 980G, or SB850 from SB950 using software. Seems their tool (BTS) knows this, but it's not disclosed... If I would know how to do that, I'd immediately implement it...
 

T.Frank

Member
Thanks for your response. I will see if I can find an technical contact from AMD to get in touch with you, to find an solution
 

Martin

HWiNFO Author
Staff member
Thanks, I'm looking forward to a response. You can tell them, I have an NDA with AMD, so it should be no problem to discuss classified information as well.
 

Martin

HWiNFO Author
Staff member
Just an update.. I have been contacted by AMD about this issue and they want to help out.
I really appreciate such support (it's not common in today's world).
 

NuclearCoffee

New Member
Martin said:
But the SB on your machine was identified as SB810/SB850, is that correct ? As far as I know, the 880G uses the SB810/SB850 too.
I know this post is old as the hills.. I've used your program for a while now it's always shown the right SB chipset, SB750/SB710, on my Main board

Gigabyte GA 880gm
 

Attachments

Martin

HWiNFO Author
Staff member
Thanks for the feedback. Sometimes it's not possible to precisely identify the AMD chipset model and not even AMD could provide me information how to do that...
 
Top