Asus ROG Strix X370-I Gaming - Fan speed mismatch



On my Asus x370-I motherboard, the sensors names for fan speed monitoring in HWiNFO64 are inverted!
Chassis report the CPU fan speed and CPU report for the Chassis.
I stumbled on this when i had AI Suite opened at the same time (as in the screenshot).

(Fan6 is AIO Pump header by the way)

Included are the debug file and a report as you ask in the sticky!





Cool! Thanks! :)

It looks like there are some temperature sensor missing for this motherboard too.
Temperature 1 and 2 match temp for CPU and Motherboard. Temperature 3 to 6 doesn't match anything and 4, 5, 6 seems to always report same temp.
But Ai suite report temp for PCH and a T_sensor probe that is optionally plugged on the board. I saw in HWiNFO settings that there is no guarantee PCH temp could be read, is it the case for this board? and is it the same case for the T_sensor probe ?

All sensor values will be fixed in the next build, so that it will match values reported by AI Suite.
Sorry i couldn't check earlier!

The new beta build seems to work great ! It display a warning about finding "Asus EC sensor" and potential impact on perf and stability when reading from it.
The value for PCH and t_sensor 1 are correctly read from this sensor. Also the label and value for the fans are matching.

On a cosmetic/usability note, the Asus EC sensor readings are displayed by default after the Hdd sensor info.
I know i can change the order in the layout settings, but is it possible to display by default just after the motherboard readings ?

While writing this comment, i was running the beta when PC crashed after maybe 5 or 10 minutes. The warning about stability is no joke!
AI suite was not running at the time but is still installed. Do you think this can have an impact ? Should i try with AI suite completely uninstalled ?
I did not have HWiNFO debug activated at the time. Do you want a debug file for this case or is it the kind of instability you are warning aboutant there is not much to do about it?
Thanks for the feedback.
I agree that the position of the ASUS EC sensor should be different, but changing the order now might break compatibility for other users, which are already using these readouts in various addons.
Usually there's no problem with stability of the ASUS EC sensor and most users have it enabled without issues 24/7. But indeed, having ASUS AI Suite just installed can cause problems, there were also cases when users uninstalled it and still some of its components remained in the system.
If you experience a crash again, it would be great if you could capture it in the Debug File.
I retried it without without uninstalling AI suite. I've had 3 crashes for now when running HWiNFO.
2 with Asus EC sensor enabled and 1 without! So I'm not quite sure what causes it anymore.

To describe the crash more precisely : At some point when HWiNFO is running, the screen go dark, the fans slow down to minimum speed, and computer is not responsive anymore. It is impossible to restart by pressing the power button. I have to switch the power supply off before restart.

The only thing is that it crash only when HWiNFO is running.

This is a debug file for a crash with Asus EC active. Crash happened shortly after launching HWiNFO, between 5 and 10 minutes.
This one is for the crash without Asus EC. Crash happened approx 30 min after launch. (30 Mo file)
I hope these debug files captured something useful about these crashes!

I will try to run it again with AI Suite uninstalled, maybe it is just coming from this...


Well, not easy to diagnose this problem remotely, but I think this might be caused by reading the GPU VRM sensor.
There are 2 things you can try:
1. Either disable the entire GPU VRM sensor (hit Del key over the additional GPU sensor showing GPU VRM values) or
2. In main settings, SMBus/I2C tab disable the "GPU I2C Support" option.
Let me know if that helped.
Yeah, remote diagnostic is not easy, so thank you !
And thanks for your suggestion ! I tried both of them with the beta.

The first one, disabling the sensor after launch (i did it with right click), still crashed the pc while GPU under load after a while.
Here is the debug file for this crash (8Mo file)

The second one when disabling I2C in settings before launch seems to be more effective !
When the GPU is not under load after an hour it still had not crashed ! So i was happy ! :) (the debug file 75Mo)

I tried one more time but with GPU under load and it did not crash after an hour. So i was even happier ! :)
It was running fine and i kinda went to do something else, letting it run. Hours later, the fans suddenly shuts down, crash! Producing a 415Mo debug file...
I don't know if it's of any use to you, but here it is :

So you're right ! The GPU VRM sensor is definitely involved, since the time before crash is largely over an hour now !

But one of this test was not under load, So i thought maybe it's related to load too.
So i tried with i2C enabled and no load and it seems stable after a fair amount of time... (here is the debug file for this run 36Mo)
Do you think it can be related ?

I'm now trying to run with the stable version with I2C enabled to see if i get a crash under load too. it's one hour in and still not crashed for the moment.
Well, it seems there might be also something else involved - the disk sensor.
So please try to disable the disk SMART sensor, or disable entire Drive Scan via settings to see if that helps.
Okay, i will try that, and report back to you.

The test with the stable version crashed in a different way...
I did two test. Both crashed the pc at different time interval and the pc rebooted itself automatically. (not like the crash with the beta)
i have the RGB LED on the motherboard match change color with temp. it was RED for both, so over 60°C.
The load was the same as the test for the beta and temp LED reporting never goes red, so temp should be the same unless some fan stops or something. Maybe it's linked to the first problem i reported (about wrong fan sensor reading)? Could that be causing instability?

I've got windows minidumps from these crashes, are you interested in those file ?
Here are the HWiNFO stable debug files : (90Mo) (1Go i think this one took longer as it's got colder in the room during the night...)
Well, this is really strange. It seems to be crashing at random places and I can't determine what exactly might be causing this.
Have you also uninstalled ASUS AI Suite ? Are you perhaps running any other system monitoring tool in parallel ?
You might also try to disable other sensors - start with the GPU, then mainboard, etc. to see if you can catch one causing this.
No other monitoring tool was running. I do have active profile in Wattman and Ryzen Master but the apps were closed.
Do they run their monitoring even when GUI is not open?
I had not fully uninstalled AI Suite... I will retry after i find how to remove it completely.
There is some service that the uninstaller does not remove... I will try again sensor by sensor as you suggest.
I won't be able to do this during the next few days but i will report back what i find when i've had time to do all these tests!
Thanks for all the time you already spent helping me! You are awesome!