Bluescreen 0x3B when an LG Ultrawide monitor with USB3 hub is connected



I have the following problem. Whenever I connect the LG 34UM95 or LG34UC97C via USB3.0 cable to my ASUS P8Z68V-Pro motherboard, I get a bluescreen as soon as HWInfo32 is loaded viat autostart on boot. The USB 3.0 Controller on that mainboard is the 3rd party ASM1042 by Asmedia.

I tried different driver version for that controller,,
And also tried flashing a newer firmware onto the usb controller. But it didn't help.
So I guess I have done all possible reagrding the USB controller.

When googling I found other people with usb problems as well. I use Windows 7 x64, the other guys use win7 or win 8 or win10. Windows version obviously doesn't matter.

So there are only 2 things left.

1. The monitor itself
2. Software

1: I had 2 LG34um95, both had this issue. Then I changed to a LG 34UC97C (which doesn't have the Thunderbolt ports compared to the 34UM95, so there is one failure possibility less, since the Thunderbolt use another ASM driver)
So all 3 monitors show the same behaviour.
And therefore I conclude it has to do with software.

Which brings me to the 2nd point.

2: Software

Either I unplug the USB from the Monitor and can boot to windows. Or I disable the usb3.0 controller driver in safe mode and the boot with the usb cable connected.
Both works.
But booting with activated usb3.0 ports and monitor gives a bluescreen.
I then analyzed those several bluescreen errors with windbg

And the faulting module is the asmtxhci.sys (the usb 3.0 driver).
But the Process name, that accessed it, is reported as HWinfo32.exe

And that is the reason why I try to get help here, after asking in 2 different hardware forums without luck.

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 3B, {c0000005, fffff88003b31064, fffff8800cb70d60, 0}

Probably caused by : asmtxhci.sys ( asmtxhci+1e064 )

Followup: MachineOwner

3: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An exception happened while executing a system service routine.
Arg1: 00000000c0000005, Exception code that caused the bugcheck
Arg2: fffff88003b31064, Address of the instruction which caused the bugcheck
Arg3: fffff8800cb70d60, Address of the context record for the exception that caused the bugcheck
Arg4: 0000000000000000, zero.

Debugging Details:

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - Die Anweisung in 0x%08lx verweist auf Speicher 0x%08lx. Der Vorgang %s konnte nicht im Speicher durchgef hrt werden.

fffff880`03b31064 488bb168010000  mov     rsi,qword ptr [rcx+168h]

CONTEXT:  fffff8800cb70d60 -- (.cxr 0xfffff8800cb70d60)
rax=fffffa800f7d98a0 rbx=fffffa800f4fa250 rcx=0000000000000001
rdx=0000000000000001 rsi=0000000000000001 rdi=fffffa80116f6240
rip=fffff88003b31064 rsp=fffff8800cb71740 rbp=000000000000016d
 r8=0000000000000000  r9=0000000000000000 r10=0000000000000001
r11=fffffa800ca29520 r12=0000000000000006 r13=0000000000000000
r14=fffff88005fd95e8 r15=fffffa800dde2de0
iopl=0         nv up ei pl nz na pe nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010202
fffff880`03b31064 488bb168010000  mov     rsi,qword ptr [rcx+168h] ds:002b:00000000`00000169=????????????????
Resetting default scope






LAST_CONTROL_TRANSFER:  from 0000000000000000 to fffff88003b31064

fffff880`0cb71740 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : asmtxhci+0x1e064

fffff880`03b31064 488bb168010000  mov     rsi,qword ptr [rcx+168h]


SYMBOL_NAME:  asmtxhci+1e064

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: asmtxhci

IMAGE_NAME:  asmtxhci.sys


STACK_COMMAND:  .cxr 0xfffff8800cb70d60 ; kb

FAILURE_BUCKET_ID:  X64_0x3B_asmtxhci+1e064

BUCKET_ID:  X64_0x3B_asmtxhci+1e064

Followup: MachineOwner

That is the blue screen analysis.
I hope there is an option to uncheck that fixes the incompatibility. Or you can fix it in HWinfo.

I unchecked the option "access embedded controllers" already but it didn't help.
Well, this really looks like a problem of the ASMedia xHCI driver which occurs when HWiNFO is trying to enumerate USB devices.
But to be sure please attach the HWiNFO Debug File capturing the BSOD so I can see more precisely where it happens. Please make sure to use the latest HWiNFO beta version when creating this report.
Yes you are right. It crashed while showing "enumerating  devices"
Here is the debug file, created with the latest beta.


  • HWiNFO32.DBG
    390.4 KB · Views: 1
Additional Information:

I plugged the monitor into a USB2.0 port on the mainboard and then there was no bluescreen.
(but this isn't a viable solution, since the monitor has a usb3.0 hub and I want to use the 3.0 functionality).
Well, indeed it's a problem of the ASMedia xHCI controller driver. The BSOD happens when HWiNFO uses standard system queries to determine properties of USB devices. That means any other software performing similar standard USB queries will cause a BSOD. Best would be if you could contact ASMedia and report this error, so they fix it.
Unfortunately I'm recently getting more and more reports of various problems with ASMedia drivers - not just USB, but SATA too. It seems the quality of their drivers is really poor.
The only way how to avoid such problems in HWiNFO would be that I add an option to completely skip scanning of USB devices.
Ok, thanks for getting a step closer to the solution.
I will try to get support from Asmedia. (But I doubt it, since they don't even publish their own drivers on their website.)
I believe that such a problem is something really serious and should not happen.
You might also try to contact you mainboard vendor (ASUS) as they are integrating ASMedia controllers and I believe their support should listen and might push it to ASMedia with a higher priority.
The more users report these problems the higher is the chance of getting resolved.
Haven't heard back from Asmedia and Asus after 24 hrs yet.
I went on on my own. Found a firmware update. But it didn't change anything.

Also usb thumb drives aren't recognizes and a usb mouse isn't recognized as well. It says, device driver for the usb device couldn't be installed.


  • USb 3.0 firmware 100803 to 120816.jpg
    USb 3.0 firmware 100803 to 120816.jpg
    35.1 KB · Views: 5
Thanks for the heads up. Please give them more time, I think ASUS should respond. They probably got more similar reports already.
I got a reply from Asus today, which doesn't really help me.
And I didn't hear from Asmedia yet

[font=Verdana,Arial,Helvetica,sans-serif]Dear Mister xyz,

thank you for your request to our support.

We cannot provide you with much help in this case. If the conenction to the chipset itself works we recommend to connect the USB hub to one of those connections. Regarding die ASMedia ports we cannot provide any updates. Maybe ASMedia can provide you with a firmwareupdate for the controller.

It might be possible though, that be two USB controllers of Monitor and ASMedia are just not compatible. We do not have any possibility to change that behaviour.

With kind regards,

Technical Support Division ASUS Germany
i.A. xyz xyz

ASUS Computer GmbH
Harkortstrasse. 21-23
D-40880 Ratingen
Germany [/font]
Oh, that's not an encouraging response.
I'd maybe tell them that ASMedia doesn't respond at all and ask whether ASUS could push this problem to them. It's part of ASUS's mainboard and they should be responsible for quality of the whole product.
Ok, I am lost (except if Asmedia will answer me, which they didn't by now).
Asus can't help me.
So either I live with it and don't have front-usb (because my case only has usb 3.0 in the front). And can't use my external backup hdd with 3.0.
Or have to buy new hardware (cheapest is a usb 3.0 pcie card, or a whole new z97 mainboard with new cpu)

This is their answer to my request of forwarding the issue to asmedia (same support worker as last time):

Dear Mister xyz,

thank you for your request to our support.

I am sorry, but we cannot provide you with any update for the ASMedia Controller in this case. We do not have any updates for it and since the motherboard is already a bit older there will be no additional updates coming from taiwan.

With kind regards,

Technical Support Division ASUS Germany
i.A. xyz

ASUS Computer GmbH
Harkortstrasse. 21-23
D-40880 Ratingen
Let's hope ASMedia will recognize that problem and fix it in a later driver update.
I have good news and bad news.

First the bad news:
Asmedia didn't answer me till now.

Then the good news:
I tried older drivers to day instead of,,

I used the asmthub3.inf so I had 2 Asmedia XHCI devices in the device manager and two additional unknown devices appeared.
For the unknown devices I used the asmtxhci.inf and had the choice to select between Generic USB Hub and USB Root Hub, I chose the latter.

And I can finally use my front usb, it shows the files on the thumb drives. Then I started HWMonitor32 and it didn't crash :D
:) Nice, thanks for the feedback. Might help other users with similar problems too.
It seems ASMedia doesn't care about any users - others had problems with their SATA drivers and they ignore that too.