GTX 850M(GM107) power monitoring issues

stratego

Member
Hello,
with the new BETA testing, I can't see GPU power measurements for my laptop, in one of the earlier versions it initially showed power values just fine, but now it doesn't show GPU Power.
The laptop is Acer V3-772G with i7 4700MQ, 14GB of RAM, GTX850M(GDDR5).
I know for a fact that monitoring works for GM107 as it works on my brother's MSI laptop with GTX 960M, so I'm not really sure what's the issue here.
here's a pic with latest GPU-Z and latest beta of HWinfo.
1591725675353.png
 

Martin

HWiNFO Author
Staff member
The GPU seems to be switched off by Optimus technology. Try to run some 3D app on it and all values should appear. Sometimes it's enough to just open the NVIDIA Control Panel with the spinning logo to wake it up.
 

stratego

Member
The GPU seems to be switched off by Optimus technology. Try to run some 3D app on it and all values should appear. Sometimes it's enough to just open the NVIDIA Control Panel with the spinning logo to wake it up.
Sorry, I wasn't clear enough it doesn't show power even when dGPU is running in 3D mode.
Here's a pic with GPU running in 3D mode
1591727351920.png
 

Martin

HWiNFO Author
Staff member
Sorry, but that still looks like the GPU is switched off. Watch the current parameters - temperature and voltage is 0.
 

Martin

HWiNFO Author
Staff member
Does GPU-Z display the actual power ?
Please attach the HWiNFO Debug File for analysis.
 

stratego

Member
Does GPU-Z display the actual power ?
Please attach the HWiNFO Debug File for analysis.
Hmm GPU-Z doesn't show the actual power, but MSI afterburner does show when GPU is power limited, so something strange going on there.
Here is the debug file:
 

Attachments

Martin

HWiNFO Author
Staff member
The NVIDIA drivers don't provide a power value. If this worked before, then I assume it changed due to a driver update.
 

stratego

Member
The NVIDIA drivers don't provide a power value. If this worked before, then I assume it changed due to a driver update.
but there hasn't been an nVidia driver update since you introduced the feature and it still doesn't explain why it works just fine on my brother's laptop and doesn't on mine as it's the same GM107 GPU chipset and if there was a silent nVidia driver update through windows it wouldn't work on both.
Both laptops run 26.21.14.4614 and it seems that my PC does as well, so that's probably the latest publicly available driver
 

Martin

HWiNFO Author
Staff member
Then try to completely Reset Preferences in HWiNFO if that will change anything.
 

stratego

Member
Then try to completely Reset Preferences in HWiNFO if that will change anything.
nope, didn't do anything, I think it might be an nVidia driver hiccup, wouldn't be the first time when nVidia drivers have random issues that just randomly pop out when you try to do something...
 
Top