HwInfo and HDD standby

doveman

Well-Known Member
I have a secondary drive which isn't used most of the time, so I've set Windows to put it to sleep after 1min.

With HwInfo/HwInfoMonitor running however, it seems to wake quite regularly, more so than when HwInfo isn't running. So I first disabled the sensors for that drive and when that didn't seem to help, disabled Drive Scan completely but I don't think it's made any difference.

So is there any way that HwInfo/HwInfoMonitor could be waking the drive with Drive Scan disabled or should I be looking elsewhere for the cause?
 

Martin

HWiNFO Author
Staff member
In case you disabled the entire Drive Scan, then HWiNFO should not be touching any drives, so I believe you should look somewhere else.
 

doveman

Well-Known Member
Martin said:
In case you disabled the entire Drive Scan, then HWiNFO should not be touching any drives, so I believe you should look somewhere else.
Thanks, that's what I thought but wanted to check before I discounted it :)
 

doveman

Well-Known Member
Hmm, I'm not so sure anymore as it's definitely spinning up the drive when I launch HwInfo manually, whilst it says "Flushing Buffers", even though I've got "Disable Drive Scan" set. Maybe it's probing the Storage Controller device and that's waking it?

That doesn't mean it's the cause of the drive regularly waking when it's running but it makes me suspicious that it could be.
 

Martin

HWiNFO Author
Staff member
Yes, that can spin up the drive in case there is some unwritten data for that drive still in cache.
But this (pre-caution) operation is performed only during HWiNFO start, so it can't be the reason for a constant drive access.
And you can disable the "Flush Buffers on Start" option anytime.
 

doveman

Well-Known Member
OK thanks, I'll disable the "Flush Buffers on Start" option to prevent that spinup on launch.
 
Top