Installation Fail When Upgrading to 6.26

Jinxtrr

New Member
Every time I startup my PC the last few days it asks me to update HWInfo to 6.26. I click it, go to the website, download the new installer, hit install (running as admin didn't work either), everything looks fine then right at the end I get this error.

hwinfo64fail.PNG

Hitting 'Retry' does nothing, and 'Ignore' seems to cancel the install reverting back to the latest version. After rebooting PC, it asks me to update to 6.26 again.

Not sure if this is a bug or not but it just keeps happening. The current version still seems to work just fine. I just can't update it for some reason.
 

Martin

HWiNFO Author
Staff member
Is HWiNFO perhaps running when you start the installer? If yes, you need to terminate it first.
If that's not the case, try to run the installer as Administrator.
 

Jinxtrr

New Member
Yes, I close out of it before running the installer and I have tried running as admin and without. Neither made a difference. I'm going to try uninstalling it completely and reinstalling the latest and see if that does it.
 

Jinxtrr

New Member
So that worked. I am running 6.26 now. After seeing posts about Vanguard, could that be causing it? I do have Valorant installed but I don't get any popup errors saying anything though.
 

Martin

HWiNFO Author
Staff member
Maybe.. Another reason might be in case you're using MSI Afterburner configured to use HWiNFO via its plugin. In that case it would automatically restart HWiNFO when it's terminated.
 
Top