Is the portable version really portable?

Nabu

Member
The version 3.91 I used recently added hwinfo32.sys to startup services in Vista. I noticed that when the backup utility in Vista Ultimate detected my drive H as system disk (I'm saving portable applications on H .)

I figured out this problem by disabling this service at startup and the backup utility recognizes only the drive C as system disk now.

Is this behaviour normal?
 

Martin

HWiNFO Author
Staff member
Every version of HWiNFO32/64 requires a kernel driver (hwinfo32.sys or hwinfo64a.sys) in order to access hardware. Without this driver it would not be possible to query 95% of information provided.
So even the portable version installs this driver into system, but the difference is that the portable one removes this driver from system when you exit HWiNFO32/64.
The installer version keeps this driver installed and inactive in system even when you exist HWiNFO. This allows faster startup.
This behaviour can also be controlled via the "Persistent driver" setting in HWiNFO: portable version has this option disabled by default.

Moreover, if you don't want to leave any traces on machine after running HWiNFO32/64, then you should disable the "Remember Preferences" option too. This will prevent HWiNFO from storing certain user settings (like screen position, user-defined sensor options, etc) in registry.

The portable version has been already accepted and approved as "Portable" by sites like PortableApps, LiberKey, Portable Freeware.
 

Nabu

Member
Thanks so much for the detailed info.

However, I cannot remember such a problem before with Vista's Backup Utility although I changed nothing in Preferences with previous versions. I always used the default settings. Could that be related to the renamed sensors, perhaps?
 

Martin

HWiNFO Author
Staff member
No, I don't think that might be related to renaming sensors.
Make sure the "Persistent driver" is off, HWiNFO closed and then check again with the backup.
 

Nabu

Member
"Persistent driver" is already off. "Remember Settings" is on by default. I changed nothing. As I said before, disabling the hwinfo32.sys at startup using a third party Startup Manager solved my problem. The drive H is being recognized as logical disk and not as system disk now. So the Backup and Restore Utility in Vista Ultimate doesn't include H by default when making a backup.

Maybe, a last question: What has the hwinfo32.sys file to do with settings? Aren't they saved in the *.ini file in application folder?

Thanks for your kind help.
 

Martin

HWiNFO Author
Staff member
The driver (HWiNFO32.SYS or HWiNFO64A.SYS) does have nothing with the INI settings.
Maybe the problem was that HWiNFO initially installed the driver on the H: drive. Is that a fixed (logical volume of a fixed disk), or a removable (e.g. USB key) drive ?
 

Nabu

Member
It's an internal and fixed hard drive with C (system, primary), D (primary), E (primary), F (logical), G (logical) and H (logical) drives on it. I usually run my portable applications from H.

(P.S: The H: drive is being recognized as logical drive in control panel. The problem was in Backup Utility only.)
 

Martin

HWiNFO Author
Staff member
And after you close HWiNFO and run the HW32inst tool what does it say? Is the driver installed or not?
Maybe also try to install/remove the driver using this tool after you close HWiNFO.. Just to see if that changes anything..
 

Martin

HWiNFO Author
Staff member
And when you press Install and then Remove, does the issue with Vista backup occur too?
 

Martin

HWiNFO Author
Staff member
Thanks. Is that a state after you did the previous step using the HW32inst tool (Install -> Remove) ?
 

Nabu

Member
Well, I installed and removed it. Restarted the PC. The entry in the Startup Manager is gone (see my attachement). And Vista Backup doesn't recognize H drive as system disk anymore.:)

(The screenshot was taken before installing and removing!)
 

Martin

HWiNFO Author
Staff member
So a restart was needed to remove that entry? That's strange.. It should be enough to make the Remove (or let HWiNFO remove it upon closing when Persistent driver is disabled).
 

Nabu

Member
Martin said:
So a restart was needed to remove that entry? That's strange.. It should be enough to make the Remove (or let HWiNFO remove it upon closing when Persistent driver is disabled).
Yes. I had to restart the system. Anyhow, the problem seems to be solved for now. Thanks again for your kind assistance.
 
Top