Latest public release breaks Stream Deck plugin?

There was a recent public update that I downloaded, and mind you, I actually decided to pay for the Pro license just to ensure Stream Deck functionality even though this license is meant to monetize professional users, and now in version 7.10-4540, Stream Deck plugin support appears to be completely broken.
 
Do you use at least version 2.0 of the plugin? https://github.com/shayne/hwinfo-streamdeck/releases
No. The latest version downloadable directly from the Stream Deck app's store is 1.1.1, and I thought Stream Deck itself would update these things, and I didn't need to dive into GitHub.. Even asking the BarRaider people in their Discord about it left me with a response telling me to downgrade to HWiNFO 6.4.2 (I've since discovered that this isn't actually a BarRaider plugin, not sure why I thought it was)

This works, thank you!
 
Last edited:

HaileSt0rm

New Member
Hi everyone, I just downloaded the plugin and hwinfo but i cant seem to select a sensor from the dropdown list within the plugin itself. It's stuck on "loading...". Any fixes?
1631603445680.png
 
Last edited:

HaileSt0rm

New Member
EDIT:

Solved with v2.0.0 of the plugin and v6.42 of HWiNFO. I was using the v2.0.1 of the plugin and v7.x of HWiNFO.

Thanks for your reply but I was wondering why v2.0.1 of the plugin wouldn't communicate with the Stream Deck?

EDIT 2:

Sorry issue came back after awhile. Sensor dropdownstuck on "loading..." again
 
Last edited:

DualNeuron

New Member
Fixed in v2.0.2 available now on Github.
I'm having the same issue and tried the given solution above, but the temperature displays still wont show up on my StreamDeckXL. I've completely deleted the HWiNFO64 from my PC + the StreamDeck store and tried downloading from the link provided with no results. I have no idea what I'm apparently doing wrong.
 
Top