Row Shading

Mr. Fox

Well-Known Member
For some reason HWiNFO row shading is no longer functioning. The sensors window does not even have gridlines. The sensor section titles and all of the sensors have a solid white background. I see this issue on my laptop (Windows 10) and my desktop (issue is present with Windows 7 and three versions of Windows 10). The desktop boots 4 versions of Windows and 2 versions of Linux, so that is not a typo. This is not aesthetically pleasing and I would like to see the gridlines and row shading. Any thoughts on the solution? Example screen shot provided below.

I assume you have the "Row shading" option enabled in sensor settings. The font used seems to be different too, have you changed it perhaps and some other UI settings?
Also wondering how did that happen on multiple machines? Was it all of sudden, or do you use the same settings everywhere?
Hi Martin. Yes, I have it enabled in the sensor settings. It seems all of a sudden. I noticed it only today and use HWiNFO at all times. I do not think I would have missed it before because I strongly dislike how it looks this way. I only tried changing the font on that example to see if that would affect anything with respect to row shading, and clearly it did not.

I am going to try downgrading the GPU drivers. That recently changed on both systems. I will report back if that corrects it.
Well, it seems the GPU driver did have an effect on it. I had installed the latest GeFarts driver and dropped back to a much older one. Windows 7 has the shaded sensor title rows and alternating banded rows for each sensor, so it is almost back to looking like normal. There are no gridlines, but other than that it's fine. Windows 10 has only the sensor title rows. On my desktop there are no gridlines. On my laptop, there are grid lines, fainter than they were before, but the sensor title rows are not shaded. Really weird. I don't understand why it changed. But, at least now I don't have super-ugly solid white sensor window background now. That looked horrible.

Desktop W7 - Shaded Sensor Titles and Banded Rows, no grid lines
Desktop - W10 Shaded Sensor Titles - no grid lines

Laptop - grid lines (although very faint) but no shading at all
Well, this is really weird. I haven't seen such issue yet, it always worked with any GPU driver and all GUI controls including row shading are done the standard Windows-GUI way.
My guess was that some recent Windows update might have introduced a bug, but if the GPU drivers are causing this then it's even more weird. Anyway, I think that other applications should be affected by this bug too.
It is very weird, but I am 99.9% certain that it was caused by installing GeForce 442.19 drivers. I am unable to identify anything else that changed across all OSes except that. I avoid updating drivers unless I have an issue that requires it. I take the position if it is working to my satisfaction, leave it alone. It might not if I change something. GPU drivers are probably the only drivers I update, and even then it is seldom. If and when I do, it is generally to spot check for a bump in benchmark scores. I often end up going back to my original optimal driver because the performance was found to have been degraded by the newer version.

And, I am pretty confident it was not a Windows Update. I only allow updates on my laptop (used for work) and only one Windows 10 installation on the desktop. My Windows 7 and Windows 10 LTSC are kept pristine to focus on overclocked benching results exclusively. Security is totally irrelevant and Windows Updates are really handy at screwing things up. I stopped allowing them to be automatically installed probably 7 years ago. This problem affected all of them the same.

I noticed that it appeared that ClearType stopped working on all of them. Screen fonts were also looking kind of rough. I also noticed things were not right with the Windows color schemes on any of my OSes after installing 442.19. It was subtle, but there was too much white. Windows 7 normally has a pale gray instead of white and I noticed Windows 7 was taking on some of Windows 10 ugliness in that regard. As I poked around a little more, I also found Windows 7 started having TDR errors just running WEI with 442.19. So, I ran DDU on everything and SFC /scannow on everything. SFC found corruption on 3 of 4 Windows installations. After running SFC, I reinstalled a slightly older driver. Now have a look. Back in business. So, my hunch is that it was GeFarts driver cancer that caused it. It appears that the NVIDIOTS screwed something up.

Last edited:
Thanks for the heads up. It's quite rare that GPU drivers cause such significant issues affecting the basic 2D/GUI. I'm wondering why didn't NVIDIA notice this, the driver is even WHQL...