Running certain games while HWiNFO is running causes the system to bog down until HWiNFO crashes

I've noticed this issue on a few occasions the last year or so (cannot remember what games unfortunately, might only be one or two, tbh), but never really spent much time troubleshooting it.

However, lately I've started playing Fallout 4 again, and I got so tired of the entire system becoming bogged down to such a degree I could hardly move other program's windows around on my desktop. The game itself will run mostly fine, but anything else in the system is severely affected. In the end I discovered that it's caused by HWiNFO.

RTX2080, 32GB RAM, i7-8700K, Win 10 Ent

- The longer HWiNFO runs, the worse it gets. Usually I notice it after 10-20 minutes.
- Game performance degrades slightly (FPS drops maybe maximum 10% in certain situations), but not really to a point where it becomes problematic.
- If I quit HWiNFO, the issue is immediately fixed. System becomes fully responsive again, and the game's performance is restored fully.
- If I restart HWiNFO again while the game is running, it will progressively get worse again.
- If I quit the game wile the issue is ongoing (with HWiNFO still running), the system performance degradation persists until I quit HWiNFO.
- If I leave HWiNFO running while playing the game, the program will always crash in the end (see event below)
- Using task manager to observe CPU usage and memory usage of the HWiNFO process does unfortunately not indicate anything unusual while this is happening.

At the moment, Fallout 4 is the only installed game where I experience this issue.
Let me know if you need more info.
Faulting application name: HWiNFO64.exe, version: 7.14.4610.0, time stamp: 0x617bcec3
Faulting module name: HWiNFO64.exe, version: 7.14.4610.0, time stamp: 0x617bcec3
Exception code: 0xc0000005
Fault offset: 0x00000000001e106d
Faulting process id: 0x678
Faulting application start time: 0x01d7fb028c5d7a0f
Faulting application path: D:\Portables\HWiNFO64\HWiNFO64.exe
Faulting module path: D:\Portables\HWiNFO64\HWiNFO64.exe
Report Id: a7201b13-ab26-4691-9cae-bcad771dfe6f
Faulting package full name:
Faulting package-relative application ID:
 
Last edited:

Martin

HWiNFO Author
Staff member
Please attach the HWiNFO Debug File when HWiNFO crashes.
You should also try to disable monitoring of some sensors (i.e. GPU) to see which one is causing this.
 
Not sure if you realize it, but the debug file is several hundred megabytes in size....

Looking at perfmon, I can see that HWiNFO is continuously writing ~10 megabyte/sec to that file (assuming it's doing some kind of rotation on the file's contents?)

Is this normal behaviour, or is my HWiNFO gone completely bonkers here?
 

Martin

HWiNFO Author
Staff member
Yes, HWiNFO can write a lot of data into the Debug File, the amount depends on system configuration. Without seeing this it's hard for me to figure out what's causing this.
Then try to disable monitoring of particular sensors to determine which one is causing this problem.
 

wonderwrench

New Member
Just a though, what antivirus software are you running? Avast has been known to crash some programs with a Exception code: 0xc0000005. Even if you are running a different brand AV try disabling it and see if you still have the slow down/crash.
 
Top