Shared Memory Support disabled if service started without user log in session

suizman

New Member
Hi, I'm using HWiNFO PRO along with Prom Dapter add-on to export my metrics to Prometheus.

My problem is that if I mark HWiNFO scheduled task to start on system start not an user login I get "Check HWiNFO Shared Memory setting". For me it looks like if the HWiNFO service is started in unattended mode it's not loading the user settings. I can see the HWiNFO is clearly running, so the problem is config related not that the service not starting on boot.
Also created a service instead Scheduled Task and allowed the app to interact with the desktop without luck. Is this related with the fact the user settings are saved in widows user register? I've tried running the task/service with the same log in user(admin) and System Local account with the same result...

What I can do in this case. I need to be able to start metrics exporter "Shared Memory Support" without having to explicitly log in to the system...
 
I think this is a different issue. When HWiNFO is started under a service, different credentials (session) are used and the client consuming data via Shared Memory (PromDapter) can't access them.
 
Hi @Martin, I've already checked that both services are running with the same user and credentials. Also installed the service for all users, only for my user(the one running the services) without luck.
Maybe you're right and starting on unattended mode windows isolate the processes and PromDapter is unable to access the Shared Memory. But it also sounds strange that "Shared Memory" is not actually being shared :D.
I'm out of ideas what more tests I can perform to identify the root cause of the issue.
 
Well, this is a special case. HWiNFO was not designed and verified to be run under in such mode - as a service without interactive logon.
 
Yes, it also works for me when I'm logged into the system and Scheduled Task is marked to "Run only user is logged on". The issues is when I mark the option to "Run whether user is logged on or not" stop the service/logout or just restart my computer and do not log in. Both HWiNFO and PromDapter services are running if I'm not logged in but nor PromDapter or HWiNFOSharedMemoryViewer are able to access the shared memory stats.

Please can you follow this steps?
  1. Mark the scheduled task to "Run whether user is logged on or not"
  2. Stop HWiNFO or kill the proccess
  3. Logout or restart(better just restart and skip step 2 to be 100% sure)
  4. Login and execute HWiNFOSharedMemoryViewer
 

Attachments

  • HWINFOSharedMemory.png
    HWINFOSharedMemory.png
    18.5 KB · Views: 3
  • HWINFOService.png
    HWINFOService.png
    24.1 KB · Views: 3
Yes, I tested it the way you described above and HWiNFOSharedMemoryViewer did show the data for me.
 
Which version of HWiNFO are you using? I'm on v7.67-5290.
I'll also give it a try on another PC

Thanks!
 
Back
Top