Hi, great program, has been so useful :), unfortunately I am getting a BSOD everytime I run the "Sensors" part of your program.  Strangely, I don't get this error on an almost identical server (the only difference is a different SSD OS drive).  I am not overclocking or anything.  I have attached the DBG file, if you require anything else please let me know.  I don't know how safe it is to make public the Microsoft BSOD error files - but will attach if required?

I assume my system information is in the DBG file but if not:

Windows 7
MB: Supermicro X8QB6-F
2 CPUS: E7-8870
128GB Ram
OS SSD: Samsung 1TB 840 EVO
Data SSD: Sandisk Ultra II 960GB


I looked in the *.DBG file using notepad and found the last entry before the blue screen of death was:

- IPMI #0
IPMI Req [NET:06 LUN:00 CMD:01]:

This reminded me that I had installed a program called SuperDoctor III (Supermicro's IMPI software) a week ago, I had installed it because I wanted to see if it would give me some more info wrt some temperature sensors with generic names in hwinfo (it didn't btw - pretty poor program). Anyway, I have just uninstalled it (and rebooted) and then tried Hwinfo64. Unfortunately the same error occurred!... anticipating that IPMI software may not have been uninstalled properly (or becomes somehow deeply embedded (bios?)) I decided to *install* it on my other server which runs hwinfo fine, see if it starts crashing?...

the good news is, it did start crashing so it appears there is a conflict between Super Doctor III and hwinfo when accessing IPMI #0 ! The bad news, for me, is I can no longer use hwinfo :( ... One thing that happened when uninstalling the superdoctor program was it asked if I wanted to remove some "shared dlls" (this program must be like 10 years old or something!), I clicked no for the ones that looked unrelated to superdoctor. So I am going to try uninstalling from server 2 (but deleting ALL shared dlls) and see if hwinfo starts working again? Seems unlikely as I would expect some service to be causing this problem. Perhaps the uninstall gets affected.... anyway, I'll post my results shortly... fingers crossed!
Unfortunately, that didn't work (even after a reboot) :(

However, I have noticed in:

Control Panel\All Control Panel Items\Programs and Features

There is still a reference to SuperDoctor, however when uninstall is clicked on it, it cannot find the file and fails. So this says to me it didn't uninstall correctly!

Any ideas?
You're right with your analysis - the problem is with IPMI. HWiNFO supports it, so it sends a query via IPMI, but doesn't get any response back and it hangs.
Since it seems to be related to SuperDoctor III, there must still be something left in the system.
I suggest to check the Device Manager and look for an IPMI driver (maybe try to list Hidden devices as well). Another alternative would be to try to install some new IPMI driver.
Thanks Martin, with your help I have finally got it working again :) Much appreciated ... I'll relay my steps in case it helps anyone else:

1) Goto Device Manager, Click "View -> Show hidden devices"
2) Expand "Non-Plug and play devices"
3) Identify the following drivers:
b) MemMapNt
c) SMBus
d) Superbmc
on each one, right click, select "Properties", click "Driver" tab, click "Stop" button. Close down this window. Right click driver again, this time select "Uninstall". You will be prompted to restart, DO NOT RESTART for any of these!
4) Go to \Windows\System32\Drivers then find the 4 files above and delete them!
5) Restart computer.

HWiNFO64 will now work for sensors section :)

It is important the files are deleted/moved in step 4 as otherwise I found that hwinfo would still crash after reboot even they they no longer appeared in device manager. After the crash they would "magically" appear back in the device manager window.

BTW, if of interest to anyone, I found these 4 files by looking in
\Windows\System32\Drivers and then adding "Company" and "Copyright" columns to the view in windows explorer. They all appeared with "SuperMicro" except for superbmc, this was the only empty one, I found it's digital signature was Super micro.

Only one of these files may have needed removing? I could try and find out but prefer not to as BSOD could cause other problems in my system! This is for anyone reading this with same problem to try ;)
Thanks for the results.
Out of those drivers you disabled, I think only the "Superbmc" is the one needed. It might be better to "Uninstall" it rather than stopping and deleting the driver files (which might result in error entries in the Event Log because the system is attempting to load them unless they are uninstalled).
Hi Martin, I did try uninstalling only (my first attempt), but still got the BSOD. It was only on deletion that I no longer get BSOD. So there is something else which I have missed, perhaps, that is triggering a re-register of these services? From my early coding days you did not have to register dll's in the windows/system directory so I am wondering whether their very existence in that location is causing the re-register?
I'm not sure exactly, but it's possible that there was another component that installed the Superbmc each time the system was booted.
Sorry for resurrecting this but I have the same problem also on a Supermicro motherboard on Windows 8.1 x64 with the latest HWInfo64 as of the time of this writing.

Unfortunately, I don't see any non-plug-and-play devices in device manager, nor can I identify the bmc controller in any of the listed devices, and I did not install any IPMI drivers. I'm at a loss of what I can do.

Is it possible to ask HWInfo to *not* query the IPMI controller?
Are you sure it's a problem of IPMI and not something else ?
Please attach the HWiNFO Debug File and I'll check that.
Yes, I'm sure. I can see it loading and deteing all sensoirs then stops at IPMI #0 then gives a BSOD ... there is no debug file, it never got past the BSOD.
EDIT: I edited the .ini file and set DebugMode=1 and the last lines in the .dbg are:
- IPMI #0
IPMI Req [NET:06 LUN:00 CMD:01]:
I'm happy to email you the full .dbg file if you wish.

NOTE: AIDA64 can read the IPMI just fine. I can see the IPMI log and also sensor resport from IPMI in AIDA64. Here's a screenshot:

So the problem thus seems to be in HWInfo64 rather than the system or drivers since AIDA64 doesn't have a problem. 

What about my question above? Is there a way to ask HWInfo64 to not query IPMI?
Please e-mail or attach the DBG file here.
Currently there's no option to disable querying IPMI.
It's in HWiNFO (About) or at the bottom of the HWiNFO homepage. You can also ZIP and attach the Debug File here.