[bug?] HwInfo doesnt store OSD settings anymore properly


Well-Known Member
Since one of the last beta builds I noticed, that HwInfo doesnt store OSD (RTSS) settings anymore correctly, for sensors/tabs which arent enabled during init phase of HwInfo. This worked before properly. Example RTSS FPS counter, or dGPU sensor readings. Even after the sensors are later avaibale, the OSD settings are reset / off.
Weird question @maffle, have you tried v6.02 yet? Is this fixed for you now?
I don't know if I was experiencing a similar issue to yours, as I was only having issues with the RTSS FPS sensor. But I am using HWINFO64 v6.02-3670 and RTSS 7.2.1 beta 5 and I was having the darnd'est time getting my OSD to cooperate the way I wanted / expected it to. I have both programs set to autostart on windows log in and even though I have set hwinfo to delay start up by 30 seconds in task scheduler, (also not sure if this is relevant but for my global profile for rtss I had "show on screen display" set always on, as in, I was not launching a game and then using a hot key to show on screen display) and on my first launch of a game the hwinfo OSD would not show. If I then exited that game and pulled up sensors for hwinfo, there would be an "RTSS" entry but no FPS counter beneath it. Without restarting the system, I could fix this by exiting the game, turning on "show own statistics" in rtss, re-launching the game, and now of course my hwinfo OSD would show, plus an additional FPS counter, the RTSS copy of the fps counter. Then if I closed the game, turned off "show own statistics" in RTSS, and re-launched it, the hwinfo copy of the osd would now display as I wanted it, without the additional copy of the RTSS own fps counter. (sorry yes I realize hwinfo is taking it's fps counter FROM rtss, and that the hwinfo osd is actually RTSS taking sensor readings from hwinfo, I'm just terrible at trying to explain this elegantly so I'm wording it as "hwinfo osd copy" and "rtss osd copy" to differentiate the two from each other and the fact that there are also Afterburner OSD settings [using afterburner 4.6.0 beta 14]). I was stubborn and kept at it.
I noticed that if I had just started up my system, and before launching a game, opened the sensors panel, then closed it, then launched the game (rtss show own statistics OFF) the hwinfo OSD would display as I had wanted it to, with the fps counter from the hwinfo sensor entry ONLY. Wait . . I have "minimize sensors on startup" checked in hwinfo settings, what if I just check "show sensors on startup" too? Yep! That did it!
Without fail, I can now start up my system, wait the 30 second delay from task scheduler for hwinfo to start (I run everything off of an NVME SSD so this is actually a *tiny* wait) and without touching anything else, launch a game and my hwinfo osd (rtss) will display everything with only the hwinfo "copy" of the fps counter showing.
Lol so I don't know if this was actually a bug or just something basic that took me a while to figure out. But I do remember running a previous version (not sure which) of hwinfo without having "show sensors on startup" checked and I was using the hwinfo osd (rtss) with the rtss fps sensor showing in the osd and not having this issue until I updated my hwinfo to the newest version. . . or Afterburner and RTSS to their newest versions. . . I updated all three at the same time so I can't actually be sure what caused my issue.
Sorry about the long read, thanks to anybody that read this far.