HWINFO v7.62, most readings of CPU turned to 0 for continuous time, Max readings broke as well


Active Member
Potential reason, graphical device being reset... Actual reason, no clue. Why CPU readings are ones that were affected - no idea. Why readings hadn't recovered, no idea. How to reproduce, no idea.
I already had long time issue of HWINFO randomly reading 0.000 V, 0 mHz and 0 degrees temps on per-core readings.
Now, different CPU and even different motherboard. 5800X3D, X570S AORUS ELITE AX, RX 6750XT.

What happened today, though, is something else. Max readings were completely out of whack, and current readings are permanently stuck at 0. So much that HWINFO decided to disable reading most of the values after some time.
And values that are recorded as max (and current L3 cache reading), are, like, 33 digit numbers of mHz! Voltage, tdie temp and PPT report themselves correct though. Basically only everything that counts stuff on per-core basis breaks.
Values of 0 at Average colum means that this stuff lasts for 2 hours or more.


And to prove it that it is not CPU that reads out wrong, here is monitoring of CPU data adjacent to HWINFO. No, secondary monitoring is not being ran for last 2 hours. It is just here to proof that CPU gives out proper readings without hitch.


UPD: Restarting HWINFO didn't help... It still cannot see CPU readings properly, while RTSS and other tools can. Here is debug file in .zip archive. 1 minute of bugged runtime when sensors were lacking.
If i run HWINFO from different .exe in different directory, everything seems to be fine.
Looks like after running secondary .exe, when i ran HWINFO from primary .exe it managed to detect everything properly again.


  • HWiNFO64.zip
    594.3 KB · Views: 1
Last edited:
This is most likely due to a collision with other monitoring tool. Does it happen when you don't use any other monitoring tool?
The fact that it works with a different exe is most likely because the one that doesn't work has the Persistent Driver enabled and when this problem happens it requires restarting the driver too. So you might need to Uninstall and Install the driver again.
This is most likely due to a collision with other monitoring tool. Does it happen when you don't use any other monitoring tool?
Never noticed my overlay (RTSS) ever showing anything with 0's. And it updates 10 times as frequently (200ms vs 2s). And it continued working correctly even after HWINFO bugged out.
And yes, i tested at some point, issue with 0-roing minimal detected values still persisted even when i disabled everything i could.
Moreover, these issue happens under actual load, for example active gaming.

Will try do logging via Adrenaline and try to catch time when critical zerofication happens (when voltages and temps go chill).
UPD: Looks like CPU actually does occasionally report 0 mHz clock, as Adrenaline logged similar behaviour... But how and why? And why EVERYTHING that is based on per-core basis reporting drops to zero?



  • 20230910-191547.zip
    309.3 KB · Views: 1
0's means the communication with the SMU failed, hence the actual values could not be read.