IMPORTANT Core frequency reading in Windows 11

Kol12

Well-Known Member
I'm getting some odd looking core frequency readings with the current HWiNFO in Win 11. Is Win 11 supported yet? Screenshot attached.
 

Attachments

  • Win 11 Core Frequency.png
    Win 11 Core Frequency.png
    91.8 KB · Views: 47

Martin

HWiNFO Author
Staff member
Currently no, it's not possible to circumvent virtualization. And it's not yet clear whether RTM Windows 11 will keep blocking this or fix it.
You might need to disable Core Isolation or Hyper-V.
 

Kol12

Well-Known Member
Currently no, it's not possible to circumvent virtualization. And it's not yet clear whether RTM Windows 11 will keep blocking this or fix it.
You might need to disable Core Isolation or Hyper-V.
I had both Core Isolation and Hyper-V enabled in Windows 10 and everything read correctly in HWiNFO but I did not get Performance Limit Reasons. I wonder if Microsoft have altered something in Windows 11 Core Isolation/Hyper-V? I thought I heard that Core Isolation/Memory Integrity would be mandatory in Win 11. I will have to try disabling it.
 

Martin

HWiNFO Author
Staff member
Yes, I believe the virtualization in Windows 11 is more restrictive, or it's some new block/filter that unintentionally blocks areas that don't need to be blocked.
I'm trying to push my luck through some contacts and discuss this with Microsoft, but don't think the chances are big..
Also looking into some workaround, but if there is any, most likely it won't be as reliable as the existing methods (which don't work here).
 

Kol12

Well-Known Member
I think HWiNFO has the status to be recognized. I wish you luck in the discussions. Keep us posted. :)
 

Martin

HWiNFO Author
Staff member
I have done some more testing, so here the results:
- This issue affects 10th Generation (Comet Lake) and earlier CPUs. 11th generation CPUs (Ice Lake, Rocket Lake) support an alternate way to read BCLK and that seems to work properly.
- The culprit is the Core Isolation feature - when enabled (which is the default setting in Windows 11), it will block a certain interface that needs to be used on 10th generation and earlier CPUs.

So my advice is to disable the "Core Isolation" feature if you you're affected by this and need to see correct BCLK
 

RobertR

Active Member
Hmmm... on my "old-fashioned" 8-th gen Kaby Lake (not the "Refresh") - and running the latest available BETA Win 11 *with* Core Isolation - the same data display of core clocks looks reasonable. The clocks vary between 800MHz and 4GHz... perhaps I just don't know what is is that is supposed to look wrong.
OTOH, maybe my older CPU just doesn't have as much locked down here - the only entry under the Core Isolation details is "Memory Integrity" - but it is ON.
HWiNFO 7.10-4540
 

Martin

HWiNFO Author
Staff member
Hmmm... on my "old-fashioned" 8-th gen Kaby Lake (not the "Refresh") - and running the latest available BETA Win 11 *with* Core Isolation - the same data display of core clocks looks reasonable. The clocks vary between 800MHz and 4GHz... perhaps I just don't know what is is that is supposed to look wrong.
OTOH, maybe my older CPU just doesn't have as much locked down here - the only entry under the Core Isolation details is "Memory Integrity" - but it is ON.
HWiNFO 7.10-4540

Hmm, that's interesting. I'd have to see the HWiNFO Debug File to check whether the limit is enforced there too.
 

Kol12

Well-Known Member
I have done some more testing, so here the results:
- This issue affects 10th Generation (Comet Lake) and earlier CPUs. 11th generation CPUs (Ice Lake, Rocket Lake) support an alternate way to read BCLK and that seems to work properly.
- The culprit is the Core Isolation feature - when enabled (which is the default setting in Windows 11), it will block a certain interface that needs to be used on 10th generation and earlier CPUs.

So my advice is to disable the "Core Isolation" feature if you you're affected by this and need to see correct BCLK
Thanks Martin. I was trying to disable Memory Integrity the other day because of another software conflict and it seemed to keep turning itself back on after rebooting. I will try again this weekend and report back.
 

Kol12

Well-Known Member
I have done some more testing, so here the results:
- This issue affects 10th Generation (Comet Lake) and earlier CPUs. 11th generation CPUs (Ice Lake, Rocket Lake) support an alternate way to read BCLK and that seems to work properly.
- The culprit is the Core Isolation feature - when enabled (which is the default setting in Windows 11), it will block a certain interface that needs to be used on 10th generation and earlier CPUs.

So my advice is to disable the "Core Isolation" feature if you you're affected by this and need to see correct BCLK
I disabled Core Isolation and my 10900K readings are now accurate. I hate to be a pain but what say I want Core Isolation enabled? Could this easily be corrected by Microsoft?
 

Kol12

Well-Known Member
Hi Martin,

Are there any updates on this? I noticed you found a workaround for AMD. Is it still not possible for Intel 10th gen?
 

Martin

HWiNFO Author
Staff member
For Intel 10th gen the change needs to be done on Microsoft side, we are unable to come up with a reliable workaround.
 

Martin

HWiNFO Author
Staff member
BTW, even Intel XTU is affected by this issue and new XTU versions will refuse to run when HVCI or Hyper-V is active and blocks access to certain overclocking functions.
Intel is also discussing this with Microsoft, but so far it looks like MS is not quite willing to lift this block.
 

avielc

New Member
BTW, even Intel XTU is affected by this issue and new XTU versions will refuse to run when HVCI or Hyper-V is active and blocks access to certain overclocking functions.
Intel is also discussing this with Microsoft, but so far it looks like MS is not quite willing to lift this block.
If I can join in (as I noticed this one with my new 11th gen intel core.
This was reflected for me, not through HWINFO but actually through the GIgabyte software where the AIO Cooler that displayers the CPU frequency is reporting the Ghz to be at 0.5ghz.

bottom line - WIndows 11 has new feature that affects and is required by WSL called "Virtual Machine Platform"
From testing this is the direct link between the frequency misreport and this feature (turning it off and on affects the system as soon as restart is done.

any ideas what can be done about it? maybe this information can help if you have direct line with Microsoft? @Martin
 

Martin

HWiNFO Author
Staff member
MS knows about this, but their statement so far was that not enough users (or customers) reported this issue so they don't feel they need to address this for now.
So the only thing we can do is that more and more users will bombard their hotline and demand a solution.
 
Top