Effective clock 4 MHz and ratio x0.04

a.griffiths27

New Member
Good evening,

Hope you are well. I am not sure if this is a bug or not but the CPU core 0 reports an effective clock speed of 4MHz under load. Ive noticed sometimes it jumps around such that three other cores report this also for a second before going back to a stable 3700mhz.

1609320853560.png

Hope this helps.
 

Martin

HWiNFO Author
Staff member
It's normal for the Effective Clock to show such low values when the core is sleeping.
 

a.griffiths27

New Member
Hi Martin, I ran prime 95 on it and had all cores running and it still shows the result above in my first post. When its not under load it drops to zero. It appears like its permanently sleeping. Have attached the debug file if that helps.
 

Attachments

  • HWiNFO64.DBG
    3.6 MB · Views: 5

Martin

HWiNFO Author
Staff member
Is the same low value shown in the sensors window too? Check also that core utilization there.
 

Oxijex

New Member
Hi Martin,

I have noticed the same bug also, everything else would appear normal.

This bug seems to occur with 6.40 ****

After thinking it was an issue with my system i came across this post and rolled back the version.

I reverted back to 6.34-4300 and it is working correctly there.

The link is https://www.fosshub.com/HWiNFO-old.html?dwl=hwi_634.exe - In case you would like to try that too a.griffiths27.
Effective clock bug.PNG
 

Attachments

  • Effective clock old version.PNG
    Effective clock old version.PNG
    73.8 KB · Views: 6
  • System Summary.PNG
    System Summary.PNG
    69.3 KB · Views: 6

Martin

HWiNFO Author
Staff member
I'm looking into this, but can't figure out what might be the problem in HWiNFO. Does it show the same if you enable the "Snapshot CPU Polling" option ?
 

Oxijex

New Member
I'm not sure where i enable that option Martin, Could it be that the "Snapshot CPU Polling" is only a selection for AM4 ?
 

Oxijex

New Member
Yeah my apologies, i missed that one,

So interestingly enough with Snapshot turned on it happens on all Cores/Threads

If i speak in language i know its like the engineering value isn't correct and is being given in Ghz rather than Mhz.
 

Attachments

  • with snapshot.PNG
    with snapshot.PNG
    97.8 KB · Views: 12

Martin

HWiNFO Author
Staff member
Thanks. I think I identified the issue, it shall be fixed in the next (Beta) build.
 

Oxijex

New Member
No worries martin,

I'll go back to the older version which is perfectly stable anyway :)

Thanks Mate,

Happy new year !
 

garych

New Member
I still have the issue related to this.
Core 0 T0 always shows higher effective clock than rest of cores.
Even when I set fixed low voltage of just 1 volt in BIOS to cause clock stretching on my R5 3600, Core 0 T0 effective clock still goes up to full boost (clearly not right), while rest of the threads go down to ~3300 MHz.
Happens on latest beta to date.
6.34 shows correct values.
 

garych

New Member
Yes, I tried that, and it works.
I didn't use it before, because Average Effective frequency value was halved. All good now. Thanks!
Although, I'm a bit curious what happened in 6.40 that led to Core 0 T0's wrong value.
 
Top