GSOD SYSTEM_THREAD_EXCEPTION_NOT_HANDLED cause by amdkmdag.sys

wawans1975

Well-Known Member
Hi Martin,
I have GSOD problem can't run HWinfo64 when ram overclocked to 4533MHz:, but using XMP 4133MHz, hwinfo64 can. Is there workaround from HWINFO64 to avoid this? just to make it run first
R7 5700G DDR4 4533 NB Clock 2267, IGP enabled and using RX 570, display through IGP.
Thanks.
 

Martin

HWiNFO Author
Staff member
I will need to see the HWiNFO Debug File to know where exactly it is crashing.
 

Martin

HWiNFO Author
Staff member
You should be able get into main settings before the scan is started or you can added DebugMode=1 into the INI file.
 

wawans1975

Well-Known Member
ok,
I managed to get debug file, here it is
 

Attachments

  • HWiNFO64IGP_DGP_DISPLAYBYIGP.DBG
    1.1 MB · Views: 1

Martin

HWiNFO Author
Staff member
Hmm, this is a really weird crash during attempt to access the LPC/SIO sensor. Nothing that should be causing such problem, so I don't think this is a problem in HWiNFO.
Is the system otherwise stable, other tools work?
 

Martin

HWiNFO Author
Staff member
Try to run HWiNFO alone without other tools.
You might also try to disable LPC support to see if that helps by putting the following into the INI file:
LPC1=0
LPC2=0
 

wawans1975

Well-Known Member
still the same, i ran other one with vsoc auto
 

Attachments

  • HWiNFO64IGP_DGP_DISPLAYBYIGPVSOC_AUTO.DBG
    1.1 MB · Views: 2
  • HWiNFO64IGP_DGP_DISPLAYBYIGPVSOC1.3V.DBG
    1.1 MB · Views: 1

Martin

HWiNFO Author
Staff member
It's crashing at very different places, do you have the "Debug Write Direct" (DebugDirect=1) option enabled? If yes, then it looks like a system instability.
 

wawans1975

Well-Known Member
I set= 1 for wakegpu and one other poll gpu(?) in ini file, running well for several minutes now, but those gone now in the ini file, dont know why..
 

Attachments

  • HWiNFO64.DBG
    1.1 MB · Views: 1
  • Screenshot (1108).png
    Screenshot (1108).png
    1.7 MB · Views: 5

Martin

HWiNFO Author
Staff member
That's quite odd as those are mostly default settings. So suddenly it runs well with such settings?
 

wawans1975

Well-Known Member
the main cause seems the wake disabled gpu option. Set that to 0 will get GSOD, the next HWinfo64 start to run.
AMD ADL and Reorder GPU already set to 0.
 

Martin

HWiNFO Author
Staff member
Then the problem must be in the GPU driver as that option initiates a very simple OpenCL sequence to wake the GPU up. That should not be crashing the system.
Try to run some OpenCL benchmark, like AIDA64 GPU stress test or benchmark.
 

wawans1975

Well-Known Member
looks like memory and nb oc (1:1) stability problem, i checked with testmem theres many errors, set the CL lower for now , looks ok . Sorry for wasted your time :D
 
Top