How to Change Fan Speed?

bahrbarian

New Member
I have an XPS15 L502X and I recently installed HWiNFO64 since I have been having trouble with my fans after doing a clean install of Win7. I have clicked on the fan button on the sensors window, and get to the part where Ican adjust fan speed, and click manual control. The fan speed doesn't ever change, however. I put it to the desired spot, and click manual control, and exit, but the fan speed doesn't change. Am I doing something wrong?
 

Martin

HWiNFO Author
Staff member
It should work the way you did it. Does the fan speed change only for a little while, or is there no reaction at all? You can verify the actual speed in the sensors window (DELL EC sensor).
If it doesn't change at all, then probably the firmware doesn't allow it.
 

bahrbarian

New Member
Martin said:
It should work the way you did it. Does the fan speed change only for a little while, or is there no reaction at all? You can verify the actual speed in the sensors window (DELL EC sensor).
If it doesn't change at all, then probably the firmware doesn't allow it.
There is no reaction at all. The fan is completely off and doesn't even turn on until my CPU and GPU get to around 90 C (which is waaaaay too hot).
So, if it is the firmware, is there any way around that? I'm not too familiar with firmware and these kinds of things.
 

Martin

HWiNFO Author
Staff member
I'm sorry, but in this case it seems I can't do anything more. The firmware simply doesn't allow it.
You should contact the vendor support, or check if there's maybe a BIOS update that fixes it.
 
Top