HWinfo 5.8 won't start

jvidal

Member
Hi!

I've been using hwinfo for years without a glitch, but today I downloaded and installed v5.80 and it won't start. It complains that it can not install the driver and that I should check user permissions or AV filters. I have not changed anything regarding user permissions (plus, UAC is off) and I have used the same AV for ages (avast).
Tried disabling the AV and running as admin, same result, it won't start.

Am I doing something wrong or this a bug that slipped through the cracks?
 

Martin

HWiNFO Author
Staff member
Try to go into Settings - Driver Management and try to Remove and Install the driver from there.
 

jvidal

Member
Thanks for the suggestion.

I un-installed hwinfo, but the driver would still be present in device manager, under non-plug n play devices. I un-installed the driver from there, but I have to reboot to know what happens...
 

jvidal

Member
Well, after uninstalling and manually removing the driver from device manager, it works again. Strange, I've never had any issues like this before...
 

Martin

HWiNFO Author
Staff member
Please attach the HWiNFO Debug File of the crash for analysis.
Do you perhaps have some antivirus? It might be blocking the driver.
 

rca626

New Member
Martin said:
Please attach the HWiNFO Debug File of the crash for analysis.
Do you perhaps have some antivirus? It might be blocking the driver.

I've got the same issue. It was working fine, then this morning I was notified of an update. I downloaded it and now it won't start and gives the same error. Says it can't load the driver. When I check under the driver management tab it says it isn't installed but the persistent driver box is checked. I also couldn't find any listing in Device Manager for it. I tried running normally and as admin. I can't find any debug file either. Where would it be stored? I looked in the program folder, My Documents, AppData; can't find one anywhere.
 

jvidal

Member
application crash, no BSOD.

This appears in the windows log:
Nombre de la aplicación con errores: HWiNFO64.EXE, versión: 5.80.3400.0, marca de tiempo: 0x5acca5f5
Nombre del módulo con errores: HWiNFO64.EXE, versión: 5.80.3400.0, marca de tiempo: 0x5acca5f5
Código de excepción: 0xc0000005
Desplazamiento de errores: 0x000000000009dae7
Id. del proceso con errores: 0x22a0
Hora de inicio de la aplicación con errores: 0x01d3d1de9cc60e3f
Ruta de acceso de la aplicación con errores: C:\Program Files\HWiNFO64\HWiNFO64.EXE
Ruta de acceso del módulo con errores: C:\Program Files\HWiNFO64\HWiNFO64.EXE
Id. del informe: e61d17b9-3dd1-11e8-a6fa-005056c00008
 

Attachments

jvidal

Member
Thanks, Martin. Yep, this one doesn't crash after closing.

PS: This board sucks!!!!!! half of the time I have to post things twice, because the posts end up empty!
 

Martin

HWiNFO Author
Staff member
Thanks for the feedback. I'm not sure about the problem with forum, no one else has yet reported such problem.
 

Introvertebrae

New Member
I also encountered a driver update issue and found out what may be causing it, at least on my end. I'm running Malwarebytes. Driver updates look to be running through driveragentplus.com, which Malwarebytes sees as malware. Hope this helps.
 

Martin

HWiNFO Author
Staff member
Thanks for the feedback.
HWiNFO driver has nothing to do with driveragentplus. I believe that the problem is Malwarebytes being overcautious with other drivers eventually blocking their install.
 

rca626

New Member
Martin said:
Try to disable the Persistent Driver option and then click Install. What happens?
Is there some antivirus or antimalware running? That might be blocking it.
Please see here how to create the Debug File: https://www.hwinfo.com/forum/Thread-IMPORTANT-Read-this-before-submitting-a-report
Disabling the Persistent Driver option and clicking Install appeared to fix the problem for me. Thanks!  :)

This problem was on my work PC, so I have no access to changing the antivirus/malware settings. When I first had this problem I uninstalled 5.8 and reinstalled 5.7 and that ran perfectly fine. With the above tweaks 5.8 is now working.
 
Top