HWiNFO Crashing


I just did a complete rebuild of my system, and now HWiNFO isn't working.

My System:
Windows 10 - New Install
Asus Z97 Extreme6
Samsung SM951 (Boot Drive)
Western Digital Green 2tb (2nd drive)
Video - Onboard VGA
HWInfO Version: 5.04.2630, then 5.06.2640 (Both versions behave the same)

I was using HWiNFO successfully on this machine (although I had only opened it once during the initial install) before I rebuilt.  Now, I was able to install, but when I run it I get the following:

While loading and gathering specs, HWiNFO stops responding at, "Detecting IDE\SCSI...", then 1-3 minutes later the computer stops responding and I have to do a manual restart (power button).

I tried disabling the Storage check and then it locks up at "Analyzing PCI BUS..."

I can't find anything in the systems event viewer that links to HWiNFO that might help identify the problem.

I also can't find a way to enable logging to see if I can produce a log to help identify the problem

Any help would be appreciated
Please attach the HWiNFO Debug File of both situation (enabled and disabled Drive scan). I'll then analyze it and give recommendations.
Thanks for the quick reply, on a Saturday.  That kind of customer service is unparalleled.

I rebuilt the system and HWiNFO is no longer causing the system to crash, BUT it is still not working  I have attached 3 debug files: Drive Scan enabled, Low level I/O and drive scan disabled.  The behavior is the same for all 3.  HWiNFO stops working at "Analyzing IDE/SCSI...."

In all 3 cases I waited approximately 2+ minutes for the scan to move past the "Analyzing IDE/SCSI...." point where it stopped.


  • HWiNFO64-Enabled.DBG
    373.7 KB · Views: 1
  • HWiNFO64-Low Level IO.DBG
    373.7 KB · Views: 1
  • HWiNFO64-Disabled.DBG
    373.7 KB · Views: 1
Thank you for the files.
This seems to be a rather strange issue, which I haven't encountered yet. I see in the report that you're using a WD My Book Live NAS storage device. Can you try to disable it to see if that changes something ?
Disconnect it from the network or turn of the management software on my computer?

I'm not sure either would help as I have multiple computers connected to the same network running Windows 7 and Windows 10. All of them have the management software for the WD NAS installed an none of them are having the issue with HWiNFO. If this issue is (local) storage related, the primary difference is the computer with the issue is the only one with a PCIe storage device (the Samsung SM951, that is the boot device for this computer). If this is related to the WD NAS, would some or all of the other computers be having the same issue running HWiNFO.

I'll try both versions of disconnecting the NAS and see what happens
I'm not sure what exactly could be the cause, since according to the DBG files you posted it seems to freeze on a standard query. I haven't seen any system freezing there yet.
So my assumption was that this query (to enumerate logical drives in system) might be waiting for some event and it might be caused by that NAS.
But if you say that this doesn't happen on other systems with the same NAS connected, it might well be the SM951 as bootable. Maybe try to upgrade its drivers ? What drivers have you used before the upgrade and was the drive bootable before too ?
Here are the results so far:

Files labeled "-1-" - I turned off the WD NAS management software

Files labeld "-2-" I disconnected the Mapped network drive

turning off the management software did not help, all 3 attempts failed to continue past the "Analyzing IDE\SCSI..."

Then I disconnected the mapped drive.

Safe mode failed
Low IO mode - SUCCESSFUL!!!!
closed program and attempted to rerun in low IO mode - failed
disable - failed

later this afternoon, I can try with the NAS fully disconnected from the network, but that seems unnecessary as the above attempts with the management software not running AND the mapped drive disconnected should have completely eliminated the NAS from being seen by HWiNFO completely.
Sorry, Here are.

The file titled HWiNFO64-2-Low IO -2.dbg is the successful attempt to load the program.  The other 6 are all failures.


  • HWiNFO64-1-Disabled.DBG
    374.1 KB · Views: 1
  • HWiNFO64-1-Low IO.DBG
    374.1 KB · Views: 1
  • HWiNFO64-1-Safe Mode.DBG
    374.1 KB · Views: 1
  • HWiNFO64-2-Disabled.DBG
    374.1 KB · Views: 1
  • HWiNFO64-2-Low IO.DBG
    525.3 KB · Views: 1
Thanks for the additional data.
So after analyzing it seems that the freezing of HWiNFO during IDE/SCSI scan is caused by the NAS drive (its drivers?). This is quite odd, since the query where it freezes is a standard one and this should not happen. It is possible that other software might freeze as well. Also note that this query is performed by HWiNFO only if Debug Mode is enabled. So when you disable Debug Mode, it should not freeze there, but in that case the other initial issue (system crash) can occur and you won't be able to provide me DBG file of that situation.
So if there's still a problem with system crash, I suggest to disconnect the NAS and capture the crash with a new DBG file for analysis.
As previously reported, the 7 files I sent were performed when:

Files labeled "-1-" - performed with WD NAS management software turned off
Files labeled "-2-" - performed when BOTH NAS software turned off AND the mapped network drive disconnected.

HWiNFO should not have had anything to query related to the NAS, especially in the files labeled "-2-". As it was, I ran it once (in Low IO mode) and it worked, but then I reran it and it didn't

I will try again with the additional condition that the NAS is disconnected from the network AND software turned off AND mapped network drive disconnected.

Either way, I need the NAS connected, AND all of my other computers (as mentioned, I have machines with Windows 7, 8.1 AND 10) all seem to work fine, as did this machine BEFORE I reinstalled Windows. So, Is there some way to have HWiNFO ignore the one incompatible driver on this machine so I can move on with completing this machine knowing HWiNFO will work for the rest of the information that I use it for?
Ok, so now I tried it with debug mode disabled (with the NAS powered on), and HWiNFO stopped at the same point (IDE\SCSI...).   This time, when it crashed it froze the computer again (unlike the previous times with debug enabled, where it only crashed HWiNFO, but I was still able to use the computer

I have attached the 3 debug files with the NAS turned off, the management software closed AND the mapped drive disconnected.  It is still crashing, although, while I had the debug mode off, it did successfully load 1 time on the Low IO mode.  But, when I closed HWiNFO and tried again to see if I could duplicate the successful launch, it crashed


  • HWiNFO64-3-Disabled.DBG
    374.1 KB · Views: 1
  • HWiNFO64-3-Low IO.DBG
    374.1 KB · Views: 1
  • HWiNFO64-3-Safe Mode.DBG
    374.1 KB · Views: 1
HWiNFO doesn't query anything specific to NAS, it just retrieves general logical drive information and that's where it hangs. This happens only in Debug Mode, so in normal usage, you shouldn't encounter this hang.
The other system crash that you see is something different, however it still wasn't captured in the DBG files because of the hang, so I still don't know exactly why the system crash happens.
Thus I think I'll remove the general logical drive information query, so that you can then capture the system crash in DBG file. I'll post a new test build in a while...
Ok, so the 5.07.2650 beta version seems to be working better.  I restored my computer via an image backup that I had created prior to HWiNFO being installed (all of the crashing and subsequent hard powering down was causing my Windows install to get corrupted.)

Using the latest version I was successfully able to get HWiNFO to run in Low I/O mode and with the disk check disabled.  This includes the WD NAS connected to the network and the management software running.

The Safe Mode setting still caused BOTH HWiNFO and the computer to freeze as before, but I'd be happy to run HWiNFO in the Low I/O mode, unless there is some other reason not to.

I have attached the 3 files so that you can continue to troubleshoot the Safe Mode setting with my configuration, but, unless there is some specific reason to continue to play around with this, I am happy installing the beta version on this computer and running in the Low I/O mode and just moving on.  The version I was using is working on all of my other computers and all of them will get upgraded when the beta becomes a final release as I am rigid about keeping EVERYTHING up to date on all of the machines (when they become final releases).

Thanks for all of your help.  I will continue to check back to see if there is an update on this and will perform any checks that you need (provide debug files), but, I suspect that I ma done for now.



  • HWiNFO64-1-Disabled.DBG
    400 KB · Views: 1
  • HWiNFO64-1-Low IO.DBG
    473.8 KB · Views: 1
  • HWiNFO64-1-Safe Mode.DBG
    440.4 KB · Views: 2
I just sent a donation for all of your help. I wish it could be more, but this was an off week for my commissioned based job. :)
Do you have an installer version for the 5.07 (portable) link that y ou posted, so I can install it on this system. The download links on the main system don't seem to have 5.07... yet
Thank you for the additional data and the donation.

I think I can finally understand the reason for the crash - this is (again) happening while querying the NAS device, though this time it's a different query that causes the NAS driver to crash and thus a BSOD. Moreover, it seems that the safe mode doesn't completely disable all disk queries and that's why you get this crash. What's even more strange is that in Low-level mode this crash doesn't seem to occur, although HWiNFO performing the same query operation on the NAS. This is really odd :) Maybe it's some interaction between the SSD and NAS drivers...
What I can do now is to fix the Safe mode, so that it completely skips all disk checks, so you'd be able to run safe in this mode too.

Beta versions are not shipped with an installer. Since HWiNFO installation is very simple, you don't need to perform any special install operations - just replace the existing installed files with the files from the portable/Beta package.
Awesome.  Thanks.

AND, since I haven't already said it....  Awesome Product!!!  And, Even better support (please feel free to use that quote on the front page of ANY marketing that you might do!!!!)