hwinfo exits/closes randomly (only if the debug option is NOT enabled)

Pernicius

New Member
Hello,

as the title says. Hwinfo starts normaly at system start. But after some minutes it disappears without any error message. But only when the debug-mode is disabled. If its enabled, hwinfo works perfectly.
The reason why i post here ist, that the debug file is growing endlessly. And because i rarely do a complete reboot the file grows to multiple gigabytes in size.

I have attached a debug file when i manually start and quit hwinfo.

System info:
- Dell Optiplex 7050
- nVidia GTX 1660 Super

What i need:
- an option to reduce the size of the debugfile
- a way to automaticly restart hwinfo when it quits

(sorry for my english, it's not my main language)
 

Attachments

  • HWiNFO64.DBG
    1.3 MB · Views: 1
Debug Mode is not intended for normal operation but I understand that you have it enabled to avoid the issue.
But it will be very tough to find why the problem happens when it doesn't occur in Debug Mode.
Try to disable some options in HWiNFO like "EC Support" if that will help maybe.
 
Hmmmm...

I have disabled the "EC Support" option and it runs for hours now.
I will report...

Thx for the super fast response :)
 
And it still quits... again...

It seems it quits only during high load of CPU/GPU. I noticed it after playing more CPU/GPU intensive games ... i will watch it and report ...

Can it be, that Windows itself shuts the process down?
Any idea where i can look at?
 
Are you maybe automatically starting HWiNFO via Windows Task Scheduler? If yes, that might be configured to terminate the task after certain time. Check the Windows Task Scheduler first..
If that's not the case, see in Event Log whether it perhaps mentions something.
 
It seems to work now. I have disabled several options (see attached HWiNFO64.INI)

Because it exits so randomly, i don't know which option caused the exit.
But... I'm happy now and upgraded to the PRO version :)
 

Attachments

  • HWiNFO64.INI.txt
    314 bytes · Views: 6
Back
Top