HwInfo locking up PC


Well-Known Member
Having a few issues with HwInfo64.

Firstly, it was working with HwInfoMonitor and then just stopped, as in the Monitor didn't display anything when HwInfo was launched, even though the settings weren't changed and Shared Memory Support was still enabled.

I was having problems with BSOD when running Plex Media Server, which I appear to have fixed by disabling an option in the BIOS "SATA IDE Combined Mode". However, the next time I ran HwInfo, my screen went blank and I had to hard reset.

After rebooting, I manually edited the options to enabled Debug Mode and Open System Summary and then HwInfo worked OK and HwInfoMonitor was working again. I then disabled Debug Mode and it still worked, then I disabled Open System Summary and the screen went blank again at the Analysing Devices stage and I had to hard reset again.

When I disabled "SATA IDE Combined Mode", at the next boot Windows installed two new devices/drivers for the IDE ports, although it still shows the same "Standard Dual Channel PCI IDE Controller" in Device Manager, so I imagine it was just the device IDs that changed and it was reinstalling the same driver it was already using. I thought perhaps this change might have confused HwInfo but I think after the next successful start it should have adjusted and it seems strange that it only works when Open System Summary is enabled anyway.
If you will experience this issue again, then please try to capture the Debug File of the crash and submit here. Without that it's hard to make judgements...
The PC's got worse now, first the NIC wasn't working (just saying "Network Cable disconnected") and now it just locks up on boot. It works OK in safemode so it's hopefully just some drivers I need to remove. Probably nothing to do with HwInfo. I did install the persistent driver but did that long before the problems started.

I'll get back to you if I manage to get the PC sorted out!
OK, the PC seems stable again now I've uninstalled Network and SoftPerfect RAMDisk :)

Attached the log/dbg from running with Debug Mode and Open System Summary enabled. I'll try again with those disabled and see if it locks up and if it generates any files before it does so.

EDIT: Seems to be fine now, with both those options disabled so hopefully I've fixed whatever was up with the system :)


  • HWiNFO64.zip
    138.3 KB · Views: 4
So does it mean there are no lockups and the files attached are from a run without problems?
Yep, everything seems fine now thanks. I just attached the files to compare in case the next run with those options disabled did crash but it didn't :)
Hmm, seems I spoke to soon.

I updated the NIC, USB3 and SATA3 drivers and connected the HDD to the SATA3 port. The system booted fine and I used it for a while but when I ran HwInfo the screen went blank again and I had to hard reset. When it rebooted, the Sidebar gadgets failed to appear and the mouse was stuck on busy and I couldn't do anything but hard reset again. I connected the HDD to the SATA2 port and rebooted and that was OK. I ran HwInfo again first with Debug Mode and Open System Summary and SensorsOnly and that was OK, then I disabled Open System Summary and that was OK, then disabled SensorsOnly and it was still OK.

I'm not sure the logs are much use but I've attached them anyway.


  • HWiNFO64.zip
    133.3 KB · Views: 4
I'm not sure exactly what could be the problem unless the Debug File captures the crash.
It might be the checking of your SATA drive under certain conditions...
Yeah, it's a bit tricky I know. I'll leave Debug Mode on and hopefully it will capture something if it happens again.
If it's a problem of the SATA drive, it might depend on its driver, or position in port. In such case, disabling the IDE/(S)ATA Drive Scan in HWiNFO might help, though you'll loose all disk related information.
With the HDD connected to the SATA2 port, which is on the AMD Chipset, Device Manager shows it's using amd_sata.sys and amd_xata.sys.

On the SATA3 port, which is run by the Asmedia chipset, it uses different drivers (I'll have to check as I don't have a note of them).

As I've had this problem occur with both though, I'm not sure what to make of it. Could it be that even when there's nothing connected to the SATA3 ports that HwInfo is still scanning them and it's having trouble with the Asmedia chipset? I guess I could try disabling the SATA3 controller in Device Manager (or the BIOS) but as this problem only seems to occur intermittently it will be hard to tell if that's helped.

There is a firmware update available for the SATA3 (and USB3) chips but I'm not sure whether to do that as it might not be suitable for my particular board (they're available from Asmedia and not the actual motherboard website, which hasn't had any driver updates since 2011, so I've had to get the latest drivers from elsewhere anyway).
Another thought I had. HwInfo wasn't loaded when I rebooted after it did crash my PC, so can't have caused the lockup at desktop before booting finished but as I have the persistent driver enabled, I wonder if that could still be causing problems? What does that install and where?

I'll try disabling it anyway just in case.
No, the persistent driver should have no impact on system when you don't run HWiNFO - it just sits idle there and waits for commands from HWiNFO.
Oh well, I'll disable it anyway for now just in case.

For your info, the drivers the Asmedia 106x SATA3 controller uses are ahcipp64.dll and asahci64.dll
Well it just happened again, hanging at scanning PCI bus and then the screen went dark and I had to hard reset.

Since last time, I've disabled the SATA3 ports in the BIOS, removed the IDE CD-ROM, moved the IDE HDD and replaced the cables for both that and the SATA HDD and ODD. Probably did a few other things as well that I don't recall!


  • HWiNFO64.DBG
    93.4 KB · Views: 2
This is a quite strange problem. This time it crashed when scanning the TV card.
Martin said:
This is a quite strange problem. This time it crashed when scanning the TV card.

I have two cards in there, a Hauppauge Nova-T 500 and a Nebula something. I did have the Nova-T 500 out of the machine for a while to help troubleshooting, so it's possible it wasn't in there when I posted the last debug log. Then again, it shouldn't cause HwInfo to lockup the system I don't think. :s
This crash was on the Nebula one. Indeed, it shouldn't happen and seems to be quite random, so very hard to diagnose.
Such crashes during PCI scan can sometimes be fixed when changing the PCI Latency timer setting in BIOS, though only few ones offer such setting.
Martin said:
This crash was on the Nebula one. Indeed, it shouldn't happen and seems to be quite random, so very hard to diagnose.
Such crashes during PCI scan can sometimes be fixed when changing the PCI Latency timer setting in BIOS, though only few ones offer such setting.

Thanks. That's the least useful card (I was only going to use the video input for dubbing VHS tapes to PC perhaps) so if it's causing problems I think I'll remove it and hopefully that will make the system stable. I've been having tons of problems with this system (although it mostly seems quite stable at the moment), so maybe they've all been related to this card!
HwInfo has been launching without problems since removing the Nebula card but I have had two BSOD since.

They might be unrelated but I think I did have HwInfo running both times, so perhaps you could check the attached dumps to see if there's any connection?

I've uninstalled SoftPerfect RAMDisk now and I haven't had a BSOD since (fingers crossed and too soon to be sure really) but it might be a coincidence or there might have been some conflict between that and HwInfo I guess.

EDIT: Hmm, I googled the BSOD error and it lead me to this https://support.mozilla.org/en-US/questions/674779

It seems I had the same problem (I'm not using Firefox though) as it was BSOD if I tried to open Windows\Fonts or go to Control Panel - Fonts and after opening \\PCNAME\C$\Windows\Fonts, selecting all 446 fonts and clicking Install to re-install them, it's not longer doing that, so fingers crossed I'm making progress, although I can't help but wonder how it got like that in the first place!


  • 073113-17019-01.zip
    42.2 KB · Views: 1