HWINFO64 Crashing when opening Sensor Settings panel

SpeedyIV

Member
I am running HWINFO v7.11-4545 beta on a Ryzen 5950X system. HWINFO has been crashing while opening the Sensor Settings panel. The changes I was making are: change color to green, add a >value for Red, and change the label. Every time HWINFO has crashed, it has been after selecting a sensor, right clicking and selecting Customize Values. I have HWINFO set to Black mode but before it crashes, the Sensor Settings panel appears in white, then the program crashes. When I restarted, all of the sensor custom values I had set were back to defaults. I should note that I have had earlier versions of HWINFO crash in the same way but did not take the time to dig into it and try to document the specifics. My point is I do not think this issue is specific to v7.11-4545 beta.

I know that HWINFO stores sensor custom settings in the Registry, but I don't know when it actually writes the values. I thought maybe it writes the setting data to the Registry when the user clicks OK in the Sensor Settings panel. This must not be the case or I would not have lost all of the sensor display settings I had set before the crash. Watching the affected Registry locations indicates that custom sensor display settings are saved to the Registry when HWINFO closes, not when the Sensor Settings panel is closed.

I then tried backing up my changes after completing the customization of a group of sensors (6 Octo fan speeds). I customized all of them and then opened Settings and clicked Backup User Settings. After the next crash, some of those settings were back to defaults. I closed HWINFO, double-clicked the .reg backup I made then started HWINFO again. The sensor display settings I had updated prior to saving the backup were still set back to defaults, so it appears that the backup .reg file did not add the new setting values to the Registry.

Lastly, while looking in the Registry, I found what appears to be 2 sets of data for my Octo. The one with values currently getting loaded into HWINFO is at Computer\HKEY_CURRENT_USER\SOFTWARE\HWiNFO64\Sensors\F00AA800_2 but there is what appears to be an earlier version at Computer\HKEY_CURRENT_USER\SOFTWARE\HWiNFO64\Sensors\F00AA800_1. This one has less entries in it (I think because I recently added 2 more fans). It also has old custom labels that I have since changed. These old labels do not get loaded into HWINFO.

My main questions are:
1 - Why is HWINFO crashing while opening the Sensor Settings panel?
2 - Does HWINFO only write new sensor display config data to the Registry when the program is shut down?
3 - Why are there what appear to be 2 different versions of the OCTO in the Registry and is this a problem?

I enabled Debug mode after one of the crashes. The attached file was generated after the next crash. I zipped it up before restarting HWINFO because I was not sure if restarting the program would cause the DEBUG file from the crash to be overwritten. Debug Write Detect was also checked. I hope I did this correctly.

Thank you in advance for any assistance.
 

Attachments

  • HWiNFO64 Debug.zip
    2.4 MB · Views: 2

Martin

HWiNFO Author
Staff member
I'm trying to reproduce this crashing problem, but can't. Can you please try to do a full "Reset Preferences" and try to repeat the procedure? If it still happens, please provide more detailed steps how to reproduce it.
As for the other questions:
2 - HWiNFO saves sensor settings when it's ordinary closed, minimized to tray or after changing the sensor settings. But I recently found a bug related to the new Dark Mode (black) that could result in a failure to save settings on closing of the configuration screen.
3 - That should not be a problem.
 
Last edited:

SpeedyIV

Member
Thank you for looking into this, and the clarification on when HWINFO saves sensor settings to the registry. I am still curious about why there appears to be an earlier version of the Octo in the registry, with the old number of fans and old labels, but I will table this question in an effort to stay focused on the crashing issue.

I Reset Preferences, closed HWINFO and opened it again (to be sure). Everything was set back to defaults.

I started to customize sensors starting with the Octo physical temp sensors. For each one I did the exact same process listed below. I completed temp sensors 1 through 4, and Soft Temperature 5. When I right clicked on Soft Temperature 6 and selected Customize Values, the Sensor Settings panel appeared briefly in white color, then HWINFO crashed.

Procedure:
Settings - Black mode, Debug enabled. Shared Memory Support enabled. EC monitoring enabled after Reset.
Select Octo "Temperature 1" (default name) sensor in Sensor Status panel. Right click and select Customize Values.
Sensor Settings panel opens to Custom tab.
Click on black box. Color box opens. Change to Green, click OK. Color box closes, color changes in Sensor Status panel.
Click on value >, enter 40 (units are already Celsius).
Click in Current Label field, delete default label "Temperature 1", type in my label "T1-RAD Front", click on Rename. Label name updates in Sensor Status panel.
Click on OK. Sensor Settings panel closes. (side note - check registry - label not updated)
Move to Octo temp sensor 2, repeat process. The only difference is the new label name.
Repeat for Temperature 3 and 4, and Soft Temperature 5.
Select Soft Temperature 6. Right click and select Customize Values.
Sensor Settings panel appears in white briefly. HWINFO crashes.
ZIP Debug file.
Restart HWINFO. All sensor settings are back to default.

Other notes.

1 - I have confirmed that when set to Black mode, the registry is not updated when a sensor setting is changed or when the Sensor Setting panel is closed by clicking OK after making the change. The registry does get updated if I minimize the Sensor Status panel, and if I close HWINFO. So it appears that the bug you mentioned is present.

2 - In my Aquasuite setup, Soft Sensors 1 to 4 are assigned to monitor fan speeds, not temperatures. These soft sensors appear in HWINFO but the default units is °C. I can change the unit Name field but I can't change the units from °C. The Units field in the Sensor Settings panel seems to not be user editable. I can get a fan RPM to display properly by multiplying the value by x100 and changing the unit name to RPM, but the Unit field in Sensor Settings still says °C. Is this the proper way to "force" a sensor that HWINFO "thinks" is a temperature to be a fan RPM value? Aquasuite soft sensors can be configured to monitor anything available, but HWINFO seems to assume they are all temperature values. I tried this based on this thread.
Many thanks for your help with this Martin. I don't mean to write walls of text but I am trying to be very detailed about exactly what I did before the latest crash. It has crashed every time I have been editing sensor display settings, after the ~4th or 5th one, including after doing a Reset Preferences.
 

Attachments

  • HWiNFO64.zip
    922.1 KB · Views: 1

Martin

HWiNFO Author
Staff member
Thank you for the exhausting report!
I have been able to reproduce this problem and narrow it down. However it seems the issue is not in HWiNFO, but internal Microsoft GUI functions. Luckily I was able to come up with a workaround for this.
So please try this build: www.hwinfo.com/beta/hwi64_711_4547.zip and let me know if the issue is fixed.
This build should also fix the problem of settings not being saved after closing the sensor settings window.
As for the inability to change sensor units, I wasn't able to reproduce this and have no issues changing them.
 

SpeedyIV

Member
Thank you Martin. I will try this beta and report back ASAP.

Does this being caused by a Microsoft GUI function mean that the issue is limited to Gray and Black modes? HWINFO was crashing every time I started customizing sensor display settings, which is something that I suspect many (most?) HWINFO users do. I am surprised that there have not been other reports of this happening.

Changing sensor units - I will play with this some more as it may well be operator error or misunderstanding. If I can't figure it out, I will make a separate post about it with screen shots showing exactly where I am having difficulty. Thank you again for your prompt responses, and for reading my long winded posts.
 

Martin

HWiNFO Author
Staff member
That crashing was not related to dark mode only, I could reproduce it standard (light) mode too.
 

SpeedyIV

Member
HI Martin. I am happy to report that I have had no crashes while customizing sensor display settings, and the registry is being updated as expected. Thank you for getting this fixed so quickly.

Regarding Octo soft sensors that are configured in Aquasuite to monitor a fan speed instead of a temperature, the confusion I have remains. I suspect I did not explain it clearly. I have attached a PDF file with 3 screen shots in it that I hope show what I am talking about. Octo Soft Sensor 1 is monitoring a fan RPM, not a temperature.

Snip 1 shows how Octo Soft Sensor one appears in HWINFO with default settings. It appears as a temperature in °C. I set it to Red to highlight which item I am referring to.

Snip 2 shows the changes I made to get it to appear as a fan speed in RPM. I renamed the Unit label from °C to RPM and added a x100 multiplier. I also changed the main label. The Unit field that I cannot change has a Red box around it. Note that it still says °C. It's not really a problem because the end result appears like I want it to in the Sensor Status panel.

Snip 3 shows how the sensor appears after these edits. Now it says RPM and the value is correct because of the x100 multiplier.

So I am able to get it to report the proper RPM value, and to say RPM. What I can't change is the Unit in Sensor Settings panel. It still says °C. I don't see this as a problem, because the end result is what I want. My question is am I doing this properly or is there a better way?

Thanks again, and I promise to stop sending you long winded emails, at least for awhile.
 

Attachments

  • Octo Soft Sensor config as RPM.pdf
    71.6 KB · Views: 4

Martin

HWiNFO Author
Staff member
Thanks for the feedback, I'm happy too that this is fixed :)
Regarding the 'issue' with sensor units - the entry you can't change is the original unit name just like the original label name to the left, hence it can't be changed. Original names are intentionally shown in case a user changes them but decides to revert back.
 

SpeedyIV

Member
Thanks for the feedback, I'm happy too that this is fixed :)
Regarding the 'issue' with sensor units - the entry you can't change is the original unit name just like the original label name to the left, hence it can't be changed. Original names are intentionally shown in case a user changes them but decides to revert back.
Thanks Martin. That is what I suspected. As I said, I was able to get the soft sensors to display fan speeds properly by multiplying the value x100 and changing the Unit label field. I just wasn't sure that what I did was the right way or the best way to do it. I hope that at least my posts were helpful in identifying and resolving the crashing issue. Thank you again for helping me with this.
 

Martin

HWiNFO Author
Staff member
Yes, your detailed reports have significantly helped me to reproduce this issue and fix it, thank you very much!
 

SpeedyIV

Member
Yes, your detailed reports have significantly helped me to reproduce this issue and fix it, thank you very much!
Well that makes me feel better. I will stay on v711-4547 beta until the next beta release, which I assume will include your fix for this issue.
 
Top