i5 1135G7 frequency display not correctly

kaori14112

Member
I'm using latest program, but frequency showing not correctly, including ram frequency.
I already install all driver for this laptop
1613817762908.png
1613817904040.png
 

Martin

HWiNFO Author
Staff member
Do you maybe have virtualization (or Hyper-V) enabled?
Can you please post the HWiNFO Debug File so I can see what exactly is happening there.
 

kaori14112

Member
I already disabled Virtualization and i do not enable Hyper-V
1613835823666.png
1613836171713.png
Here is debug file:
 

Attachments

  • HWiNFO64.DBG
    2 MB · Views: 1

Martin

HWiNFO Author
Staff member
This is very strange and I haven't observed such issue yet. Something seems to be messing up either the timers or internal counters.
Are other tools (i.e. CPU-Z) showing such erratic clock too?
 

Zach

Well-Known Member
Try ThrottleStop too to check CPU clocks.

@Martin, I’m sure you notice on the OP screenshot of sensors the “Bus Clock”. It’s what causing all the other false reports.
 

Martin

HWiNFO Author
Staff member
Try ThrottleStop too to check CPU clocks.

@Martin, I’m sure you notice on the OP screenshot of sensors the “Bus Clock”. It’s what causing all the other false reports.

Yes. Intel CPUs support a reliable method to read actual BCLK since a few generations, which is a great feature.
But there are some exceptions where this doesn't work. Tiger Lake-UP3 is one such exception where no reliable method to detect BCLK works so we have to use other methods based on measuring CPU clock/ratio. This works relatively OK, but in this case for some (unknown) reason this gives insane results.
 

kaori14112

Member
CPU-z does respond with correct frequency, but RAM frequency is incorrect @[email protected]
Capture.PNG
I'm running 2 sticks of ram bus 3200 but it reported ~800Mhz

1613991790870.png


Windows reported no problem
1613991524543.png

HWmonitor does report correctly:
1613991637061.png


I dont know where problem came from, i did a test on my friend laptop (acer but with a same CPU then it's showing normally, only happen on my HP laptop).
Do you think HP ruin the driver or something?
 

Attachments

  • 1613991493069.png
    1613991493069.png
    26.4 KB · Views: 4

Martin

HWiNFO Author
Staff member
Please try to disable the "Use HPET" option in HWiNFO Settings - Safety and let me know if that changed something.
 

kaori14112

Member
Still the same, debug files attached below: (2 files, disable HPET and not disable HPET)
1614069633604.png
 

Attachments

  • HWiNFO64.DBG
    2.1 MB · Views: 1
  • HWiNFO64_not_disable_HPET.DBG
    1.2 MB · Views: 1

Martin

HWiNFO Author
Staff member
This is very strange and I have to admit that I don't know what exactly is going on there but something seems to be affecting the timers. Or maybe somehow blocking only HWiNFO. Is there any special software installed?
I have also noticed that even if you have Virtualization disabled, the "Microsoft Hyper-V Virtualization Infrastructure Driver" is active. So I suspect the Hyper-V is still somehow active and causing these issues.
 

kaori14112

Member
I did perform reinstallation windows (20H2) and did not install anything except winrar + hwinfo, and i already disable Microsoft Hyper-V..." in Device Manager.
Other soft like CPUz still work normally. I will try to reinstall older windows version (1909) and check if problem still happen.
#update: still the same on 1909 version :(
Debug file attached bellow:
1614095382614.png
 

Attachments

  • HWiNFO64.DBG
    1.3 MB · Views: 1
Last edited:

Martin

HWiNFO Author
Staff member
Thanks, I think I'm getting closer to understand what's happening here, yet not sure how to fix this.
Could you please export the following key using the regedit tool and post it here: HKEY_LOCAL_MACHINE\Hardware\Description\System\MultifunctionAdapter
 
Last edited:

kaori14112

Member
I just reinstall newest version of windows, here is registry export file
 

Attachments

  • MultifunctionAdapter.zip
    5.1 KB · Views: 1

kaori14112

Member
This time i saw it pretty accurate! Debug file attached it you need it.
On the first start (without debug mode on) i saw it jump to 6Ghz on a moment, but after exit and relaunch application then it's seem ok now!
May i know what causing it behave like that?
1614237361735.png
 

Attachments

  • HWiNFO64.DBG
    2.3 MB · Views: 2

Martin

HWiNFO Author
Staff member
Thanks, great to see such an improvement.
Problem here is that several methods to accurately determine the actual bus clock (from which other parameters are derived) don't work on this system. Intel offers a very accurate method that for some reasons was not implemented on these series of CPUs. So we have to use less accurate methods that sometimes cause a glitch in measurement.
I was attempting to use a different (though much more accurate) method, but this won't work here either as the system is configured to hide certain devices that would be needed for this.
 

kaori14112

Member
Thanks, great to see such an improvement.
Problem here is that several methods to accurately determine the actual bus clock (from which other parameters are derived) don't work on this system. Intel offers a very accurate method that for some reasons was not implemented on these series of CPUs. So we have to use less accurate methods that sometimes cause a glitch in measurement.
I was attempting to use a different (though much more accurate) method, but this won't work here either as the system is configured to hide certain devices that would be needed for this.
I did a test on my friend Acer laptop (using the same CPU with this), seem like it's working pretty normally on that.
I did try to enable virtualization back and seem like it's wont affect a result.
I really appreciate your taking the time to help me. I have been searching for a long time with bunch of software but none of that work.
If you need anything just ask.
Thank you.

1614241636779.png
 
Top