Latest Intel UHD driver causes issues.


Active Member

I have some reporting errors since the latest intel UHD driver for UHD750 driver 3222.

If you check the included picture you will notice discrepancies between hwinfo64 and gpu-z , gpu-z seems to be the more correct one (though gpu temperature reported is wrong with gpu-z).

Does this need to be fixed by intel or did they change something and hwinfo64 needs an update ?

Schermafbeelding 2022-07-29 115218.png
At your request, files have been attached.


    244.5 KB · Views: 2
  • HWiNFO64.DBG.7z
    194.2 KB · Views: 0
The GPU clock you see in HWiNFO is what's reported by the Intel GPU driver.
You might try the latest HWiNFO Beta version 7.27 which has some improvements here for later Intel GPU drivers but it's quite unlikely that you'll see a change here.
If Intel says this is the GPU clock, it should be so.
With all previous drivers it reports it's idle clock being 350MHz and clocking to 1300 when busy, only with this latest driver it gets reported as being 1300MHz all the time which isn't correct for sure.
Also the igpu vid gets reported as being 0.370 to 0.402V when in idle, it get's reported as 0 V with all previous drivers in idle.
Seems to be the same joke as amd and nvidia had recently when their stuff didn't get reported anymore because of some driver changes, they both fixed it with a newer driver.
If intel says the core temps where 0° C on rocket-lake, where they correct then also ? They fixed that with a microcode update i recall.
So no , Intel is not some flawless god, i don't care what they say or claim. If you can't fix it then they must.
Have you tried the latest HWiNFO Beta version? That adds a new (3rd) method to read actual GPU clock.
Same results with the latest beta 4.27-4830. Is there something i should set manually for this new method to read the clock or is it enabled by default?
Just a follow up to let you know the CPU i7-11700k has died on me just before reaching its 8 months of usage, something must have gone wrong during the silicon lottery i suspect.

I got a new one under warranty. I hope this one will last a bit longer; this is terrible from intel for a CPU that never got overclocked and ran within intel specs.
Another follow up, with a new cpu, new intel driver, new bios with updated cpu microcode, the results are the same, igpu gets reported as being full clockspeed always.
The other values like power usage seem to be in order this time, just not downclocking.

If the cpu dies again within days, i'll be pretty sure as to what caused it. A borked Intel design what supposedly should be the pinnacle of their previous (non hybrid) designs. Kind of a joke this would be.
A small update to this issue,

By chance i discovered that the clockspeeds remain at idle (350) instead of staying at max (1300).

How i got to this is because windows keeps reverting new intel igpu drivers to old versions, the only thing i did different this time instead of running the intel installer again was to change the driver back to the latest manually in windows device manager. I chose to manually select the latest and so the driver got updated back to the latest and strangest of all , This time the igpu clockspeeds remained 350 at idle.
Whenever i use the intel driver installer , the clockspeeds get stuck at max clock. So i seem to have found a solution/workaround to the problem.

@Martin, do you have any clue as to what is going on with this fenomena??
and to return to the same problem again after the first reboot. Another proof of what a joke those big companies really are, they just get lucky their shit even works.