MSI 6340 HWiNFO freeze on sensors


Well-Known Member
As Martin undoubtely noticed, I recapped this old interestingly designed MSI 6340 mobo:
MSI_6340_complete_small.jpg I run a HWiNFO on it... :D And it does work, but it freeze on the sensors screen, not showing them at all. No idea why. What makes this all even more interesting is, that MSI claims that the mobo does not have sensors.
The problem - with bios v4.0 I seen the sensors and their output in the bios. The catch? In v4.7 bios they are gone. I could be mistaken, but there is screenshot from ModBin that show, that the menu there exist in the old bios version, so I'm not making it up:


Anyway, used latest HWiNFO v4.25-2013 and as I say, it run:

It just freeze when I click on the sensors (it scan the sensors, took it's time and when the little scanning windows close, then it freeze and cannot be exited, not even terminated by taskman - and not even by procexp can the HWiNFO be terminated, witch is quite unusual and make me worry...), so... Everest run and even show "sensors" - just the HDD. Suxx :(

Because I did this before, then I include in the attachment:
- CPU-Z report
- Everest report
- HWiNFO report
- HWiNFO debug when I hit the sensors

I believe that this is all what one can supply. Now if you excuse me, I would take a look what software can modify the FSB on KT133 chipset on the run, so I can score some overclock results for HWbot:
3DMark 2001 is not enought :D

PS. bugging Franck about this mobo too, as the latest CPU-Z (1.66.1) did not show FSB on this mobo and futher testing reveal, that oder version (1.61.3) does. And even futher testing reveal, that same situation is on KT266A chipset mainboards and what is worser, on KT600 mobos the CPU-Z (both 1.66.1 and 1.61.3) freeze the mobo! Old version 1.38 work fine on the KT600 (Soltek mobo)... So if you happen to got any FBS ideas - feel free to share. FSB (100MHz) is well detected. Ram clock is FSB+33, usually, depends on bios settings.
Overclocking in bios does not work, each value end up by running at FSB about 30MHz - ane believe me, 256MHz Duron is somewhat slow :D


  • MSI 6340
    110 KB · Views: 5
This is really strange - HWiNFO hangs during measuring of CPU clock when sensors are opened. However the same operation is performed during startup scan and when the summary window is active too and there it seems to work without issues...
I'm afraid, I don't know why this happens, maybe something related to timers ?
Well, don't ask me - I have no idea what this could be. Could you disable the measuring to see, if the sensors window will open? Something like... closed beta that will not read/show in the sensors the CPU clock?

I don't know. Reading the values of the CPU seems to work fine on CPU-Z 1.61.3 ...

Timers seems to be strange - check the issue with overclocking. Any O/C settings in bios ending up with the FSB ~30MHz situation, witch seems to be good only for testing issues - or perhaps a 12h + SuperPi 32M run for the HWbot achievement :)
New beta of CPU-Z detect the FSB:

(the "unknown CPU" only means that AXP this MSI 6340 board does not support, so...)

...however validation for the new beta does not work, as there was introduced a new validation format - a chaos from numbers and letters, 3 784 bytes lons, so validator only complains that::
File cpuz_54.cvf upload : OK
Dump corrupted !

:) least HWbot used my image for the MS 6340 mobo main display:
and I'm in the process of gathering all the highest scores with it :)
The fact, that clock measurement works prior to starting the sensor scan leads me to think that the sensor scan triggers something which renders the clock measurement not to work anymore.
The only item I found in the dump was guess what? ;) SMBus scan. So please try to disable SMBus and check if that helps maybe...
Nop, it won't be that easy, sadly. So upon the startup, I choose the options, disable the SMBus support and run the program. Clicking on the Sensors button show the small scanning progress window and then... not freeze, but... no sensors window and WEIRD mouse movement, lol.

When I say weird, I mean weird. Right and top works, but moving down and left end up reversed, most of the time, so... something like that. You can imagine. Keyboard works, deactivating and reactivating the HWiNFO window works too, but no way in hell it could get any futher. Close (Alt F4, as the mouse are fucked up) don't work either, same for Windows. Power button works, tough, and ended up this missery.

Next time - with debug :)

But... I tried old good SpeedFan and quess what! It got the voltages wrong and temps as well (unless the mobois catching a fire right now, witch did not seems to be happening), but it works. It complain a lot, tough:

SpeedFan 4.31
ERROR collecting CPU Usage : 1 (Unable to locate the "Processor" performance object)
Win9x:NO 64Bit:NO GiveIO:YES SpeedFan:YES
I/O properly initialized
Linked ISA BUS at $0290
Linked VIA VT82C686 SMBUS at $5000
Found nVidia TNT2 Model 64 / TNT2 Model 64 Pro
Linked nVidiaI2C0 SMBUS at $3D403E3F
Linked nVidiaI2C1 SMBUS at $3D403637
Scanning ISA BUS at $0290...
Scanning VIA SMBus at $5000...
INFO : unable to use VIA686 sensors (bad I/O BASE)
LM80 found on SMBus at $2D
Scanning I2CNVidia SMBus at $3D403E3F...
Scanning I2CNVidia SMBus at $3D403637...
SMART Enabled for drive 0
Found ST3200822A (200,0GB)
End of detection


SpeedFan debug included. I should also mention that I upgraded the CPU to AXP 2500+, witch is completely unsupported by the mainboard, lol. But I would quess that anyone can see that from the previous CPU-Z screenshot.

And even exit from SpeedFan works, lol.

The HDD temp and the CPU fan results from SpeedFan can roughly agree.

And now there are the promised debug after I disable the SMBus AND I also disable the CPU clocks completely.
But no help...

But this info should do it, nop? :)


  • Speedfan
    2.9 KB · Views: 2
  • HWiNFO MS6340 debug no SMBus no CPU
    18 KB · Views: 2
You're right, this is totally weird. This time it seems to hang when reading disk SMART attributes, but this obviously worked before too, so I think there was something triggered which causes random crashes/hangs. But I have no idea what it is.. Maybe if you would make more runs you'd experience different effects of the faulty behavior with same settings.
So the SMBus isn't the trigger and I think it works properly and can be enabled. Maybe try to disable the "Evaluate ACPI Methods" option (or any others) ?
I don't know, but I give it a try. However I want to report that the mainboard identity was discovered! :)

Long time ago I wanted this mainborard to be added into HWbot:

I always mentioned that "it is not terribly clear, witch is the official name of this thing." So it was ended up with the MS-6340 as is the MSI label.

Later I wanted adding picture of the mobo there:
...and it was there for long time, before recently go missing. Hopefully they put it back ;)


However with recent Aida64 report, it become clear that the mainboard is in fact a MSI K7TM Pro:
"MSI K7M Pro (MS-6340M)/K7TM Pro (MS-6340)"

Google search for pictures of "MSI K7TM Pro" confim that:

Including logs of the Aida64, HWiNFO and CPU-Z.


Yes, it took me some time, but I believe that it is better later that never. The mobo have, however, unique feature and that is being able to run at FSB 34.5MHz: it is kinda worth keeping, even the overclock is virtually nonexistant :s


  • MSI K7TM Pro - aka MS-6340
    53.8 KB · Views: 2