No core clocks shown and VID stuck on high value (Gigabyte X570 Aorus Elite w/ Ryzen 7 3700x)

AMDoc

New Member
HWiNFO64 v6.12 somehow doesn't show my core clocks and my core VID values are all locked at 1.55v while other application (like CPU-z, see screenshot below) show variable values which are much lower. Tried resetting the settings (confirmed my HWiNFO64.INI being empty). Attached my debug file.

No clocks on both positions and VID always the same:

noclocks.PNG
noclocks2.PNG
CPU-Z proof of values:
cpuz.PNG

System: Ryzen 7 3700x on a Gigabyte X570 Aorus Elite with firmware F5d (AGESA 1.0.0.3 ABBA firmware).
 

Attachments

Last edited:

Martin

HWiNFO Author
Staff member
Looks like something is blocking access to certain internal CPU registers (MSR).
Was this problem occurring with previous BIOS version?
Are you perhaps running some virtualization?
 

AMDoc

New Member
@Martin
Wait, what, this is a thing? I have virtualization (SVM) enabled because I sometimes need to run virtual machines, but this is just running on the host. Disabling SVM in the bios indeed allows HWiNFO to show my real VID and the clocks (see attached screenshot). Thanks for pointing me in the right direction, at least I know what to do to make it work now.

Do you have any idea why this happens on the host machine and why CPU-Z still show clocks per core and core voltage in the GUI (see below)? Although, they don't show up in the report txt (see attached). Are those values displayed in CPU-Z fake when I have SVM enabled? :confused:

cpuz-SVM-enabled.PNG
 

Attachments

Martin

HWiNFO Author
Staff member
According to the dumps, CPU-Z is affected as well, but I think in such case it's falling back to some alternate method for reading clocks and VID values. This method, however might be less accurate. You might compare CPU-Z results with and without SVM and I believe you'll see a difference there.
Enabling SVM only should not cause such issues, but I suspect it's Microsoft Hyper-V, which when enabled is taking over and virtualizing the CPU resources. Try to enable SVM but disable Hyper-V and see how it will behave then.
 

AMDoc

New Member
Interesting, Hyper-V, Virtual Machine Platform and Windows Sandbox were enabled, but disabling those features from Windows Features didn't fix it. This is when I noticed HWiNFO displaying: "Microsoft Hyper-V is active. Some results might not reflect real hardware !" (I didn't earlier). :oops: But I disabled Hyper-V, what's going on?

Well, apparently, I've also had Virtualization-Based security enabled (verified this by opening System Information and scrolling down). Disabling Core Isolation (Memory Integrity) eventually fixed it while leaving SVM enabled. I'm going to have to decide what I'm going to do with this information, but thanks Martin for thinking with me, it helped a lot.
 

Ryzen_Mike

New Member
I kinda had a similar question or issue. I just recently turned on SVM and haven't had any issues. Yesterday I found the option in windows security to enable Core Isolation so I turned it on. (It doesn't show the option unless virtualization is active.) After that I realized while doing a stress test HWINFO was missing info like cpu clocks, etc. I figured it had to do with the Core Isolation so I wanted to verify if the problem was happening on my laptop as well. To my suprise my Alienware laptop with Core Isolation enabled was reporting everything fine. Was curious if this is only an AMD issue or if there is a work around to get it to work with Core Isolation.
 

Martin

HWiNFO Author
Staff member
I'm afraid there's no way for a guest application to break out of the VM sandbox. The rules are defined by VMM (Microsoft) and when it doesn't allow to access some resources (i.e. registers to measure core ratios) we might only look for some alternate solution, which however are not accurate.
 
Top